Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-25-2015, 10:25 AM   #11
Senior Member
 
Join Date: Oct 2011
Location: Central California
Posts: 2,243
Regardless if the battery is a true deep cycle, RV/Marine or regular automotive 12V what you describe shouldn't happen. If that battery was new, I suspect the issue is in your converter.
__________________

__________________
2007 Chevy Duramax LMM/Allison
2012 Jay Flight 29QBH
2012 Jay Flight 26BH (Sold)
clubhouse is offline   Reply With Quote
Old 04-26-2015, 11:27 AM   #12
Junior Member
 
Join Date: Apr 2015
Location: Prévost
Posts: 25
Quote:
Originally Posted by mitchmitchell View Post
Be sure to check the fuse on the battery, we blew ours the first time we put the slide out. Everything worked on shore power, but no battery power at all.
Changed the fuse and everything works Battery is at 2/3. If the fuse blows again I will contact dealer.
__________________

Nick is offline   Reply With Quote
Old 04-28-2015, 01:04 PM   #13
Senior Member
 
Join Date: Jul 2014
Location: CANADA
Posts: 368
New TT Battery

Quote:
Originally Posted by Nick View Post
Changed the fuse and everything works Battery is at 2/3. If the fuse blows again I will contact dealer.

Check your power tongue jack. We have a new X213 and ours was a piece of crap. The metal was all rough and slightly out of round so there was not enough power to pull the leg all the way up. Like trying to fit a square peg in a round hole. Ours kept blowing the fuse. Since replacing the power tongue jack, no issues.
__________________
2015 Jayco X213
2014 Ford F-150 Platinum EcoBoost w/ MaxTow
SilverEscape is offline   Reply With Quote
Old 04-28-2015, 01:11 PM   #14
Junior Member
 
Join Date: Apr 2015
Location: Prévost
Posts: 25
Quote:
Originally Posted by SilverEscape View Post
Check your power tongue jack. We have a new X213 and ours was a piece of crap. The metal was all rough and slightly out of round so there was not enough power to pull the leg all the way up. Like trying to fit a square peg in a round hole. Ours kept blowing the fuse. Since replacing the power tongue jack, no issues.

Thanks,I'll check when I get home after work. Will keep you posted.
Nick is offline   Reply With Quote
Old 04-28-2015, 07:04 PM   #15
Junior Member
 
Join Date: Apr 2015
Location: Prévost
Posts: 25
Quote:
Originally Posted by SilverEscape View Post
Check your power tongue jack. We have a new X213 and ours was a piece of crap. The metal was all rough and slightly out of round so there was not enough power to pull the leg all the way up. Like trying to fit a square peg in a round hole. Ours kept blowing the fuse. Since replacing the power tongue jack, no issues.

Checked the tongue jack and it seems in good order. Also it's a 3500 lbs capacity.
Nick is offline   Reply With Quote
Old 04-28-2015, 07:21 PM   #16
Senior Member
 
Join Date: Jul 2014
Location: CANADA
Posts: 368
Quote:
Originally Posted by Nick View Post

Checked the tongue jack and it seems in good order. Also it's a 3500 lbs capacity.

Well that's good. Ours also came with a 3500. Was replaced with a 2500 and I couldn't argue much since we needed it (ours was unusable) and I didn't want to pay another $40 to have another shipped.
__________________
2015 Jayco X213
2014 Ford F-150 Platinum EcoBoost w/ MaxTow
SilverEscape is offline   Reply With Quote
Old 04-28-2015, 07:34 PM   #17
Junior Member
 
Join Date: Apr 2015
Location: Prévost
Posts: 25
Quote:
Originally Posted by SilverEscape View Post
Well that's good. Ours also came with a 3500. Was replaced with a 2500 and I couldn't argue much since we needed it (ours was unusable) and I didn't want to pay another $40 to have another shipped.
It sucks that you had to pay shipping when it was under warranty....
Nick is offline   Reply With Quote
Old 04-28-2015, 07:46 PM   #18
Senior Member
 
Join Date: Jul 2014
Location: CANADA
Posts: 368
Quote:
Originally Posted by SilverEscape View Post
Well that's good. Ours also came with a 3500. Was replaced with a 2500 and I couldn't argue much since we needed it (ours was unusable) and I didn't want to pay another $40 to have another shipped.

Well the dealer was supposed to refund me and didn't.
__________________

__________________
2015 Jayco X213
2014 Ford F-150 Platinum EcoBoost w/ MaxTow
SilverEscape is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.