Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-12-2014, 09:38 AM   #1
Junior Member
 
Join Date: Nov 2014
Location: The Woodlands
Posts: 3
Onan 5 kw generator start problem

I have a Jayco Precept 5 kw generator which has not been run in probably 5 months since it was at Camping World for 3+ months being "serviced" under warranty and I don't think it was started during that time. I have tried to start it several times with no success. Help!
__________________

precept is offline   Reply With Quote
Old 11-12-2014, 03:02 PM   #2
Senior Member
 
ALJO's Avatar
 
Join Date: Oct 2014
Location: Sparwood, BC
Posts: 1,329
Send a message via Skype™ to ALJO
May be you have checked already; First thing to check is if you have fuel available and if you have ignition. Otherwise be more specific about the problem.
__________________

__________________
2014 Ram 1500 CrewCab 4x4 5.7 Hemi 3.92 Rear and Air Lift 1000
2005 Jayco Jay Feather LGT - 29Y GVWR-7000 lbs.
Pro Series 1200 lbs. WDH with Double Sway Bar.
Champion 3100/2800 watt Inverter/Generator-Onboard Solar Power

ALJO 'Forever Young @ Heart' provide on their travels Music Entertainment to Senior Care Homes
ALJO is offline   Reply With Quote
Old 11-12-2014, 05:20 PM   #3
Junior Member
 
Join Date: Nov 2014
Location: The Woodlands
Posts: 3
The RV gas tank is at 1/8 and so fuel may be the problem. I plan to fill to 1/2 Saturday and see if that may be the problem. I have no idea at what level the generator fuel suction line takes off the tank and it is not mentioned in the manual. Thanks for your assistance.
precept is offline   Reply With Quote
Old 11-12-2014, 08:16 PM   #4
Senior Member
 
Clayton4971's Avatar
 
Join Date: Oct 2013
Location: Michigan
Posts: 353
Quote:
Originally Posted by precept View Post
The RV gas tank is at 1/8 and so fuel may be the problem. I plan to fill to 1/2 Saturday and see if that may be the problem. I have no idea at what level the generator fuel suction line takes off the tank and it is not mentioned in the manual. Thanks for your assistance.

I have had this happen several years ago with our Mh . They have a safety feature that when your tank gets below a 1/4 tank the gen can't get any more fuel . It's really a good thing so when you get ready to go your tanks not empty .
Clayton4971 is offline   Reply With Quote
Old 11-13-2014, 08:44 AM   #5
Senior Member
 
Join Date: Apr 2011
Location: Southwest Florida
Posts: 748
Try a different fuel supply first. I had one at Onan for warranty because it wouldn't start and that's the first thing they do.
OnTheGo is offline   Reply With Quote
Old 11-13-2014, 10:50 AM   #6
Junior Member
 
Greyhawk's Avatar
 
Join Date: Nov 2014
Location: Avon, Indiana
Posts: 22
If it still wont start after filling the fuel, try starting the coach engine and then try to fire the genny.

I had this problem with ours just last week, and from what I have figured out is that the genny uses the van battery to start from and mine was down a bit from just sitting, but once i turned the engine on the genny fired right up.
Greyhawk is offline   Reply With Quote
Old 11-13-2014, 11:13 AM   #7
Senior Member
 
D&MAKAFUN's Avatar
 
Join Date: Jul 2014
Location: KC MO
Posts: 358
Quote:
Originally Posted by Clayton4971 View Post
I have had this happen several years ago with our Mh . They have a safety feature that when your tank gets below a 1/4 tank the gen can't get any more fuel . It's really a good thing so when you get ready to go your tanks not empty .
Yep, that's what the manual says.My money is on a start and run after fueling.
__________________
Darrell, Mary & K.C. Toller Mix
In our hearts: Goldens, Tess & Jericho
'15 Jayco Precept 31 UL "Bertha"
'13 Wrangler Sahara...AKAFUN
Roadmaster base plate
Ready Brute Elite towbar and brake combo
D&MAKAFUN is offline   Reply With Quote
Old 11-13-2014, 11:26 AM   #8
Member
 
Join Date: Nov 2014
Location: las vegas
Posts: 61
the generators are very fussy, first gas tank must be 1/4 full, second the carbs gunk up real easy with the junk gas we buy, since it nearly impossible to work on carbs to clean because of emissions, 2 suggestions , 1- they suggest you run at a minium of every 30 days under a load,2- have a fuel line shut off put in and run until dry, next best new carb about 700 dollars thats what happened to me not under warranty, thanks cali for tough emissions standards that are not needed
walkingeagle is offline   Reply With Quote
Old 11-30-2014, 08:16 PM   #9
Junior Member
 
Join Date: Nov 2014
Location: The Woodlands
Posts: 3
Thanks everyone for the advice. Turns out to be the carburetor. Camping World, 55 miles from my home, was to do some warranty work on the RV. It was 1 month+ before they even looked at it and my list of problems. Then 2 more months before completing the max 1 week's work and did not run the generator once. Done with them!
__________________

precept is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.