Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 01-25-2014, 07:36 AM   #11
Senior Member
 
greenenvy1's Avatar
 
Join Date: Jun 2012
Location: Nova Scotia, Canada
Posts: 519
Quote:
Originally Posted by clutch View Post
I wonder which started burning, the truck or the trailer.
From reading around I heard it might have been a cracked oil line spraying oil on the hot turbo. I have NO idea though. But I would tend to agree that this started in the engine compartment of the truck.
__________________

__________________
1990 Jayco 250 Special
2008 Ram 5500 DRW 6.7, Cummins, Aisin auto
Holland/Binkley 5th wheel, Reese Dual Cam, and more
232,500 kms in 2013
200,000 kms in 2014
160,000 kms in 2015
greenenvy1 is offline   Reply With Quote
Old 01-26-2014, 08:01 AM   #12
Senior Member
 
Redhorse 823's Avatar
 
Join Date: Jan 2014
Location: Brandon FL
Posts: 717
+1 bad day
__________________

__________________

Tom
2014 Jay Flight Swift 294 BHS
2012 Silverado 2500HD 6.0L
Redhorse 823 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.