Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-23-2014, 10:06 AM   #1
Junior Member
 
Join Date: Apr 2014
Location: Aubrey
Posts: 6
Security Light issue

We recently bought a used 2009 Jayco Recon TH and when we did the inspection both the front and back security lights worked. Took it for it's maiden voyage and neither of them work now. I replaced both bulbs, checked the fuses (although none were specific to the lights) and they still don't work. Everything else works that I can tell. Any advice on what to check?
__________________

jtaubrey is offline   Reply With Quote
Old 05-23-2014, 05:35 PM   #2
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
I would be inclined to think there is a "kill" switch for the security lights past the exterior porch light or cargo lamps switch....good luck
__________________

Threebutchers is offline   Reply With Quote
Old 05-23-2014, 08:40 PM   #3
Senior Member
 
Paintinfool3's Avatar
 
Join Date: Apr 2014
Location: Fort Wayne
Posts: 1,272
yeah I would be flipping switches I know they should be on a separate switch
Paintinfool3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.