Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-29-2017, 07:10 PM   #1
Member
 
Join Date: Apr 2017
Location: Jensen Beach
Posts: 69
12v outlet drivers side console

Lost power to this outlet this afternoon when driving back from trip. We have the Patriot II remote unit and our Garmin 770 plugged into it. Both had been working fine for some time. I imagine there's got to be some kind of a fuse for this outlet somewhere that someone might know about Thanks!
__________________

__________________

Gus and Jeanette and the Hunter Dawg in
Jada's Hut (a 2017 Precept 35S) towing a
2016 Jeep Cherokee High Altitude Limited
Palms is offline   Reply With Quote
Old 05-30-2017, 06:41 AM   #2
Junior Member
 
Mitch S's Avatar
 
Join Date: Feb 2017
Location: Beckley
Posts: 28
We had the same problem on our 16 Alante, there's a fuse box in the engine compartment. It's a 20 amp fuse. On ours the box is almost in the middle above the radiator. Hope this helps you.
__________________

Mitch S is offline   Reply With Quote
Old 05-31-2017, 09:39 AM   #3
Member
 
Join Date: Apr 2017
Location: Jensen Beach
Posts: 69
Hi Mitch. I found two boxes on top of the engine air filter. The smaller one on the bottom of the two seems to have relays. On the larger one on top of it, after depressing the metal tab on the driver's side and pulling that part all the way towards the front, I'm still unable to open the box itself. I'd add some pictures of what I'm talking about but haven't mastered that ability yet (wants me to indicate a link but I only have them on my desktop). Any ideas as to how to open the box cover to look for the blown fuse? Thanks again!
__________________

Gus and Jeanette and the Hunter Dawg in
Jada's Hut (a 2017 Precept 35S) towing a
2016 Jeep Cherokee High Altitude Limited
Palms is offline   Reply With Quote
Old 05-31-2017, 08:17 PM   #4
Junior Member
 
Mitch S's Avatar
 
Join Date: Feb 2017
Location: Beckley
Posts: 28
I believe there is a cover latch on the lower left corner of the box. It took a pretty good tug to get the cover to open.
Mitch S is offline   Reply With Quote
Old 06-19-2017, 08:36 AM   #5
Member
 
Join Date: Apr 2017
Location: Jensen Beach
Posts: 69
Well I had to have the service technician I go to show me where it is and in effect, it's just as described by Mitch S and others, I just couldn't figure it out. Don't know why it blew a 20 amp when only had the GPS and Patriot II brake monitor plugged into that socket. Will keep an eye on it. Thanks all!
__________________

Gus and Jeanette and the Hunter Dawg in
Jada's Hut (a 2017 Precept 35S) towing a
2016 Jeep Cherokee High Altitude Limited
Palms is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.