Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 12-12-2017, 12:18 PM   #1
Senior Member
 
Join Date: Jan 2015
Location: Sierra Vista
Posts: 142
heater comes on to quickly

We have a 2015 jayco precept 35un when we need to run the heat it will start up and run up to setpoint some times it flame will shut off fan will run then flame will come back on then comes up to setpoint shuts off normally but then about 30 seconds later it will start again we have a coleman mach hp themostat with digital screen black any suggestions
__________________

stimpey is offline   Reply With Quote
Old 12-12-2017, 08:55 PM   #2
Member
 
street rod 37's Avatar
 
Join Date: Jan 2016
Location: Evansville
Posts: 49
I have a 35 un Precept like yours and I have noticed the same thing. The other day I played with it and it seemed I had lost gas pressure once it ran a while it leveled off and ran like it was suppose to. Try running stove first to get gas flowing see if it makes a difference. Hope this helps
street rod 37 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.