Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-18-2015, 08:20 PM   #1
Junior Member
 
Join Date: Aug 2015
Location: Livingston
Posts: 3
Macerator working?

Hi,

we got our new Jayco Precept with built-in macerator about two months ago. I've tried it two or three times since then, but every time I hit the 'macerator on' switch on the water panel, I don't hear a thing. Should I hear the motor running, or is it really that quiet? Can anyone who has the macerator tell me how loud the thing is?

When I poke my head behind the panel there are wires hooked to the switch, and there is no dedicated fuse for the thing. I'm hoping the whole thing doesn't need to be replaced.
__________________

hallyn is offline   Reply With Quote
Old 10-18-2015, 09:07 PM   #2
Junior Member
 
suprstreet's Avatar
 
Join Date: Mar 2015
Location: Kingston
Posts: 10
I use the macerator on every trip. you will hear it and you should see the hose fill(expand) as it is pumping. Have not had to trouble shoot problems with it yet.
__________________

__________________
Bill & Meaghan
2016 Precept 35UP
Kingston, NY
suprstreet is offline   Reply With Quote
Old 10-18-2015, 09:12 PM   #3
Junior Member
 
Join Date: Aug 2015
Location: Livingston
Posts: 3
Quote:
Originally Posted by suprstreet View Post
I use the macerator on every trip. you will hear it and you should see the hose fill(expand) as it is pumping. Have not had to trouble shoot problems with it yet.

Thanks - sounds like mine is not working then From what I've seen in forums I still hold out hope that there's just a wire somewhere that needs to be connected.
hallyn is offline   Reply With Quote
Old 10-18-2015, 09:20 PM   #4
Junior Member
 
suprstreet's Avatar
 
Join Date: Mar 2015
Location: Kingston
Posts: 10
hallyn, you should join the precept owners group. There is a lot of good people over there with great information.
__________________
Bill & Meaghan
2016 Precept 35UP
Kingston, NY
suprstreet is offline   Reply With Quote
Old 10-19-2015, 09:11 PM   #5
Senior Member
 
D&MAKAFUN's Avatar
 
Join Date: Jul 2014
Location: KC MO
Posts: 358
Quote:
Originally Posted by suprstreet View Post
hallyn, you should join the precept owners group. There is a lot of good people over there with great information.
On the header above, click "community", then click "Social Groups", then find Precept Owners Group on the right and join us.
Can't help with the macerator.
Darrell
__________________
Darrell, Mary & K.C. Toller Mix
In our hearts: Goldens, Tess & Jericho
'15 Jayco Precept 31 UL "Bertha"
'13 Wrangler Sahara...AKAFUN
Roadmaster base plate
Ready Brute Elite towbar and brake combo
D&MAKAFUN is offline   Reply With Quote
Old 10-19-2015, 09:17 PM   #6
Senior Member
 
D&MAKAFUN's Avatar
 
Join Date: Jul 2014
Location: KC MO
Posts: 358
I'm running behind...........you have joined us. Welcome
__________________
Darrell, Mary & K.C. Toller Mix
In our hearts: Goldens, Tess & Jericho
'15 Jayco Precept 31 UL "Bertha"
'13 Wrangler Sahara...AKAFUN
Roadmaster base plate
Ready Brute Elite towbar and brake combo
D&MAKAFUN is offline   Reply With Quote
Old 10-21-2015, 11:23 AM   #7
Junior Member
 
Join Date: Aug 2015
Location: Livingston
Posts: 3
Thanks suprstreet and D&MAKAFUN - I did join Haven't yet re-posted the question there.
__________________

hallyn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.