Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-19-2017, 12:41 PM   #1
Junior Member
 
Join Date: Aug 2017
Location: Port Alberni
Posts: 4
New Power Converter shows 3V, not 12V

We had power issues where shore power was not working for interior lights and not charging coach batteries.
Decided to upgrade electric panel to WFCO 8900 Power converter with WFCO T30 Transfer Relay.
Have attached pictures showing smaller older power converter with new power converter.
Now I am showing only 3V on the output of the converter (right side of panel). The batteries are charging up only while driving through the main batteries and the interior lights only use coach batteries and discharges coach batteries.
The 12V side of the power panel has small LED lights that are supposed to light up when voltage is available in circuit. None of them are lit up any more although I think they were lit after installation.
Have checked 40 amp reverse polarity fuses and they seem OK.
Think that the key may be that I am seeing only 3 volts on coach 12 volt side?
Any ideas?
Could it be a ground some place?
Attached Thumbnails
IMG_2000.jpg   IMG_1942.jpg   IMG_2004.jpg  
__________________

magoo2016 is offline   Reply With Quote
Old 08-19-2017, 12:52 PM   #2
Senior Member
 
Vicr's Avatar
 
Join Date: Apr 2016
Location: Snohomish
Posts: 307
Where is your negative battery lead terminated?
__________________

Vicr is offline   Reply With Quote
Old 08-19-2017, 01:05 PM   #3
Junior Member
 
Join Date: Aug 2017
Location: Port Alberni
Posts: 4
Will post an updated "after" install picture later.
Both the positive and negative battery terminal have a connection on right side of panel.
magoo2016 is offline   Reply With Quote
Old 08-19-2017, 02:48 PM   #4
Junior Member
 
Join Date: Sep 2016
Location: Cedar City, UT
Posts: 29
WIFCO Panel

I've had WIFCO's in a couple of RV's I've had, worked great too. Right now my RB195 has a WIFCO 3750. I suggest you get a manual for your WIFCO. Research the 12V side. I bet you will find that there two (2) fuzes on the 12V side, and the manual will explain their location. If you have changed your power panel, be sure you have terminated your ground exactly as it was on the previous panel. Good luck....
__________________
2017 NISSAN PATHFINDER, 4 WD
2016 Jayco 195 RB
Campers & Fishers is offline   Reply With Quote
Old 08-19-2017, 04:17 PM   #5
Junior Member
 
Join Date: Aug 2017
Location: Port Alberni
Posts: 4
WIFCO Panel

thanks for your comment.
That is what I will be doing first now that I have time.
Is it true that the LEDs on the right side of panel for 12 volt connections light up when connected properly?
magoo2016 is offline   Reply With Quote
Old 08-19-2017, 05:53 PM   #6
Junior Member
 
Join Date: Aug 2017
Location: Port Alberni
Posts: 4
Have confirmed that I am getting 12 volts at panel and have confirmed that the cables are not reversed. Checked the 2 40amp fuses on panel and they are good.
The 2 cables from battery show 12V before I plug them into panel but after plugging into panel shows 3V?
Can confirm that it is a problem within panel I guess.
will now focus on panel and12V wiring.
magoo2016 is offline   Reply With Quote
Old 08-20-2017, 12:04 PM   #7
Junior Member
 
Join Date: Sep 2016
Location: Cedar City, UT
Posts: 29
I cannot say for sure because I'm not sure about your model, but, there is a fuse on the inside of the box on one of the printed circuit boards. The WIFCO manual for your specific model will give you the details. Good luck
__________________
2017 NISSAN PATHFINDER, 4 WD
2016 Jayco 195 RB
Campers & Fishers is offline   Reply With Quote
Old 08-20-2017, 04:48 PM   #8
Junior Member
 
Join Date: May 2017
Location: Crestview
Posts: 21
Send a message via AIM to BillV Send a message via MSN to BillV
Black pig tail wire should be in a dedicated circuit breaker (15 or 20 amp minimum). I cut black wire off beyond the pig tail.
BillV is offline   Reply With Quote
Old 08-20-2017, 04:52 PM   #9
Junior Member
 
Join Date: May 2017
Location: Crestview
Posts: 21
Send a message via AIM to BillV Send a message via MSN to BillV
Double check your two 40 amp fuses.
__________________

BillV is offline   Reply With Quote
Reply

Tags
coach battery, power converter, shore power, wfco 8900

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.