Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-16-2018, 03:23 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 8
No Power for Generator

I recently had the coach batteries replaced with 2 6V ones, and initially I thought everything was OK, till I tried to use the generator. The Generator will not start, and its control panel has no lights, also the starter on the Generator itself does nothing. I have looked thru all of the breakers that I know of, including a check under the bed.

HELP! Not even sure where to look at this point.

Thanks in advance
__________________

__________________
Kevin and Kerry Jo
2016 Jayco Precept 35UN
2015 Chevy Equinox AWD
Roadmaster Sterling Tow bars and Invisabrake
overrun is offline   Reply With Quote
Old 11-16-2018, 03:27 PM   #2
Senior Member
 
NickM's Avatar
 
Join Date: Sep 2016
Location: Cincinnati
Posts: 400
Not sure if a pair of 6V batteries are correct. I replaced my house batteries in July on a Precept 35S, requires 2 x 12V.

If the 6V batteries are in parallel like my 12V batteries then you won't have enough power to crank the generator starter motor.
__________________

__________________
Nick, Sharon and Fin the wonder dog.
NickM is offline   Reply With Quote
Old 11-16-2018, 03:53 PM   #3
Senior Member
 
Join Date: Sep 2017
Location: midwest
Posts: 511
does anything else work? is the lighting dim? if so are you sure you have them hooked up correctly? you should have 12v on the + side one battery and the - of the other battery...

also the generator has it's OWN set of cables.. so if you had someone do it did they hook those back up?
curver900 is offline   Reply With Quote
Old 11-16-2018, 04:13 PM   #4
Junior Member
 
Join Date: Sep 2012
Posts: 8
Yes Everything else still works with no dimming, even the Inverter. There are two wires to the batteries. Two connecting positive of one and negative of the other.

The two batteries are joined together + to - with a jumper, to make one large 12V, just a lot more amps than before.


Perhaps this may also be helpful, the Bypass switch does not help either. I am wondering if it is something closer to the generator.
__________________
Kevin and Kerry Jo
2016 Jayco Precept 35UN
2015 Chevy Equinox AWD
Roadmaster Sterling Tow bars and Invisabrake
overrun is offline   Reply With Quote
Old 11-16-2018, 04:41 PM   #5
Senior Member
 
WinnieView's Avatar
 
Join Date: Nov 2017
Location: anytown
Posts: 1,751
There may be a positive or negative that was not reconnected and it feeds the generator.

We changed our two 12 volt coach batteries out this year for two 6 volt from Costco wired in series and everything works just as it should.
WinnieView is offline   Reply With Quote
Old 11-16-2018, 04:55 PM   #6
Junior Member
 
Join Date: Sep 2012
Posts: 8
Resolved

It works now! Took another look at the wires, and two lines were on the - terminal, but looking inside its bushing, the line was red. Hooked up the line also to the + terminal and now the generator is working

Thanks for the ideas!
__________________

__________________
Kevin and Kerry Jo
2016 Jayco Precept 35UN
2015 Chevy Equinox AWD
Roadmaster Sterling Tow bars and Invisabrake
overrun is offline   Reply With Quote
Reply

Tags
battery, generator, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.