Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 01-26-2016, 07:57 AM   #1
Junior Member
 
SherpaTravels's Avatar
 
Join Date: Feb 2015
Location: Houston
Posts: 28
Precept Rearview Camera Mystery

Our 2015 Precept 31UL has cameras on the outside mirrors activated when the turn signal is used. They worked fine for a while, showing the lane we were turning into on the monitor on the JENSEN radio. Now they show the opposite lane from the one we are turning into. That is, for a left turn the camera on the right mirror is activated, and vice versa.

No work was done on the RV between the time they worked correctly and when they malfunctioned other than CW installing a InvisiBrake system for our toad.

Neither Jayco or Camping World or JENSEN had any advice.

An ideas? Thanks.
__________________

SherpaTravels is offline   Reply With Quote
Old 01-26-2016, 09:51 AM   #2
Senior Member
 
mowdoc's Avatar
 
Join Date: May 2015
Location: Las Vegas!!
Posts: 158
Yeah, it looks to me like CW got a circuit crossed when wiring the brake for toad. You could return there and explain what happened. Be sure to talk to the Tech who did your work as he knows what went where.

If you are handy, you can remove the four screws holding the wood looking plastic center piece holding radio and simply reverse the camera leads on back of radio. There are three and you need to reverse left and right - leave rear alone.
__________________

__________________
2015 Jayco Precept 35UN
Towing JEEP TJ with Roadmaster plates and bar w/Blue Ox Patriot brake
OR
an Aluma low bed trailer with HD Road King and/or Polaris RZR onboard
mowdoc is offline   Reply With Quote
Old 01-26-2016, 12:42 PM   #3
Junior Member
 
SherpaTravels's Avatar
 
Join Date: Feb 2015
Location: Houston
Posts: 28
Thanks, Mowdoc. When I first saw the problem I did remove the radio and reverse the leads so I would have a temporary fix but I still would like to know what happened in the first place. The CW tech had not been near the leads at the back of the JENSEN radio. The leads are labeled Camera 1 and Camera 3 and the inputs to the radio are likewise labeled. So now when Camera one is activated the monitor in the radio identifies it so Camera 3.

The trigger signals from the turn signal to the JENSEN which tell it video feed to display are somehow reversed.
SherpaTravels is offline   Reply With Quote
Old 01-26-2016, 03:29 PM   #4
Senior Member
 
mowdoc's Avatar
 
Join Date: May 2015
Location: Las Vegas!!
Posts: 158
Got a lot of questions/variables.

Did CW also wire tail lights on toad at same time brake controller was? If so, did you add additional fixtures or use OEM tail lights and chop into vehicle wiring?

Do mirror cams work correctly if no toad? How about when toad is connected?

Are cams actually reversed sides or could they be in "mirror mode" where the image on screen is reversed? That would appear to be a right cam when you was looking at left cam. (make sense?)
__________________
2015 Jayco Precept 35UN
Towing JEEP TJ with Roadmaster plates and bar w/Blue Ox Patriot brake
OR
an Aluma low bed trailer with HD Road King and/or Polaris RZR onboard
mowdoc is offline   Reply With Quote
Old 01-27-2016, 09:01 AM   #5
Junior Member
 
SherpaTravels's Avatar
 
Join Date: Feb 2015
Location: Houston
Posts: 28
The cameras work the same whether the toad is connected or not. They are not mirror mode. They showed the wrong side of the RV (until I switched the inputs to the Jensen radio).

I don't believe CW had any reason to get into the vehicle wiring. All he did was run a wire from a plug he installed on the rear to a LED he mounted in the dash. The LED lights when the InvisiBrake in the toad is braking. My best guess is that he inadvertently did something while under the dash which caused the problem.

The earlier Precepts had Clarion radios instead of Jensens, and they had a module somewhere under the steering column where the trigger signal from the turn signal stalk determined which camera video to send to the Clarion. Roger, at Jayco, told me the Jensen does not need the module as the trigger signals go directly into the Jensen.
SherpaTravels is offline   Reply With Quote
Old 01-27-2016, 11:28 AM   #6
Senior Member
 
mowdoc's Avatar
 
Join Date: May 2015
Location: Las Vegas!!
Posts: 158
You could open door to RV and turn on right signal. If you see the door on screen then you are looking at right side with right camera. Easy test. Now you know which side is actually coming on.

I am guessing the CW tech wired tail lights and stop/turn lights on toad at same time brake was installed?? If so, did he use the original light fixtures on toad or did he add extra fixtures for towing?

Is the red LED on dash some equipment that came with brake controller or an idea the tech had?

Your info is correct - the Jensen takes camera trigger directly from turn signal circuit in RV.

I believe you have two options at this point if everything is working OK. You could continue driving just as is or return to CW and see if tech can straighten things out. If he added extra light fixtures, for instance, he could have a screw invading the vehicle harness causing circuit to be confused. If he chopped into toad harness for extra lighting he could have mis-wired something. I can't go much farther without seeing the project - sorry.
__________________
2015 Jayco Precept 35UN
Towing JEEP TJ with Roadmaster plates and bar w/Blue Ox Patriot brake
OR
an Aluma low bed trailer with HD Road King and/or Polaris RZR onboard
mowdoc is offline   Reply With Quote
Old 01-30-2016, 01:08 PM   #7
Member
 
Join Date: May 2015
Location: Galloway
Posts: 33
I found the side cameras pretty much useless. They offer no better view than the mirrors and you take your vision further away from the road looking at the monitor. Also if you're approaching a tricky interchange they take the nav screen away. I just disabled mine.
__________________

__________________
2015 Precept 35UN
airman2o2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.