Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-30-2014, 03:38 PM   #21
Member
 
Join Date: Sep 2014
Location: Dade City
Posts: 99
We have a 2015 Jayco Precept 31UL. Have not had any wind noise around the windshield. Get a lot of creaking noise from the passenger window and cabinets above. Only issue is none of the TV's work on generator power. Don't know if this is normal. When we did our walk thru they told us it worked on all power, shore, generator and inverter. He never told us about inverter so don't know how or if it works. Phone cells to dealer never get returned. Any help out there?
__________________

Jacobsnc is offline   Reply With Quote
Old 09-30-2014, 04:01 PM   #22
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 4,190
Quote:
Originally Posted by Jacobsnc View Post
We have a 2015 Jayco Precept 31UL. Have not had any wind noise around the windshield. Get a lot of creaking noise from the passenger window and cabinets above. Only issue is none of the TV's work on generator power. Don't know if this is normal. When we did our walk thru they told us it worked on all power, shore, generator and inverter. He never told us about inverter so don't know how or if it works. Phone cells to dealer never get returned. Any help out there?
You might want to consider starting a new thread with your question about the TVs. It will likely get more visibility in either the "Tech" section or the "Problems" section.

Sorry, I don't have an answer for you....
__________________

__________________


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 01-01-2015, 03:00 PM   #23
Junior Member
 
mjpachuta's Avatar
 
Join Date: Dec 2014
Location: Lansdale, PA
Posts: 16
Hi Chuck & Cindy.
Congrats on your new Precept!
We took delivery of our 2015 31UL in August 2014 and noticed wind noise from day one. It was tough to nail down, but we think we have it narrowed to the driver's side sliding window latch, even though the noise sometimes seems to be emanating from the front, or even the passenger window.

We isolated it by releasing the window latch and the noise deceased significantly. When fastened, the latch was pushing the sliding windows apart.

The dealer remedied by adjusting the latch and by adding small vent shields to the exterior drip vents on both sides. Although we haven't yet had the chance to verify this fix at 65+ mph, the noise is not there at 50 mph.

Good luck!
__________________
2015 Jayco Precept 31UL
Toad => 2013 Honda CR-V using Blue Ox Tow bar
mjpachuta is offline   Reply With Quote
Old 08-30-2015, 10:44 PM   #24
Junior Member
 
Join Date: Aug 2015
Location: West Hurley
Posts: 8
Try covering the 4 rain weep holes at the bottom of each side window with tape. That reduced my noise problem. Trying to locate rain weep hole covers for the 1 1/4" long slots.
__________________

saarf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.