Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-26-2017, 04:53 PM   #1
Senior Member
 
Join Date: May 2016
Location: Muskoka ON
Posts: 155
EMS installed

I installed my Progressive Industries EMS-HW30C today, the install went pretty smooth, the product looks well-made and very good instructions with it as well. I took my time and looked things over thoroughly before cutting the cable. The trailer is a little too far from an outlet at my house right now but I will take my generator up and give it a try tomorrow, I made up a plug for my generator as well with the neutral and ground bonded. It will be nice to know the trailer is protected now. Here is a link about running a generator with an EMS and checking for a floating neutral
http://www.progressiveindustries.net/videos
John H is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.