Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-15-2015, 12:25 PM   #1
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 256
Electric water heater Whitehawk 33BHBS

Howdy yall.

Electric water heater worked fine last night. Heard a "pop" and just thought trailer was cooling down after A/C was turned on after traveling in 102 degree heat.

DW went to ahower this morning and had cool water.

15amp breaker was tripped. Reset and tripped again after 15 minutes.

Turned off power switch and flipped on LP water heater.

Any ideas as to why electric water heater is tripping?

__________________

__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Old 08-18-2015, 04:59 AM   #2
Junior Member
 
Join Date: Mar 2015
Location: NKY
Posts: 8
I just took my Whitehawk in on Friday for warranty work on the same issue. When we took delivery, the electric water heater didn't work on our maiden voyage. Has worked fine after the initial problem, now doing the same thing you described. I'll let you know the findings once I hear back from dealer.
__________________

Fire_Medic is offline   Reply With Quote
Old 08-18-2015, 05:04 AM   #3
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 256
Quote:
Originally Posted by Fire_Medic View Post
I just took my Whitehawk in on Friday for warranty work on the same issue. When we took delivery, the electric water heater didn't work on our maiden voyage. Has worked fine after the initial problem, now doing the same thing you described. I'll let you know the findings once I hear back from dealer.
My appt for warranty work is set for the 29th. With high school football games firing back up, don't see us going anywhere for a while.
__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Old 08-25-2015, 12:21 PM   #4
Junior Member
 
Join Date: Mar 2015
Location: NKY
Posts: 8
Just got a phone call from the service department. Found a bad heating element. After replacement, no issues. This is the second heating element in this unit. Hope the info helps! Good luck!
Fire_Medic is offline   Reply With Quote
Old 08-25-2015, 01:31 PM   #5
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 256
Quote:
Originally Posted by Fire_Medic View Post
Just got a phone call from the service department. Found a bad heating element. After replacement, no issues. This is the second heating element in this unit. Hope the info helps! Good luck!
Thanks for the update!!

We drop ours off this Saturday. Hope it doesn't take too long.
__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Old 09-06-2015, 07:00 AM   #6
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 256
Still waiting. It's been 1 week. No word as to what's going on.
__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Old 09-06-2015, 08:20 PM   #7
Senior Member
 
us71na's Avatar
 
Join Date: Jun 2013
Location: McKean, PA
Posts: 428
Disconnect the leads to the heating element and use an ohm meter to check for continuity between the tank wall and the heating element terminals. If it reads 0 ohms you have a bad element.
__________________
2011 Skylark 21FKV
us71na is offline   Reply With Quote
Old 09-12-2015, 07:45 PM   #8
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 256
They called me Thursday. Heating element bad. Parts ordered. Will take 10-12 days to get parts in. Had the TT in for two other warranty issues. Hopefully won't take much longer. Ready to travel again.
__________________

__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.