Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-17-2014, 09:52 AM   #1
Member
 
Join Date: May 2014
Location: Stagecoach, NV
Posts: 61
First time using furnace

I turned on the furnace for the first time. I read where you need to let the oils, etc. burn off the first time you use it. I turned it on and set off the smoke detetor. Is this a reasonable thing to expect?
__________________

__________________
Jack
Stagecoach, NV
NevadaCamper is offline   Reply With Quote
Old 06-17-2014, 10:19 AM   #2
Senior Member
 
Join Date: Feb 2014
Location: MD
Posts: 3,082
I've heard of others say running the furnace the first time to open windows vent and door for the smells/fumes to clear out. So I guess it could set off the smoke detector. Mine gave off no smells no smoke or anything the first time we used it.
__________________

__________________
2017 JayFlight 28BHBE
2014 JayFlight Swift 264BH (Sold)
2007 GMC 2500 Sierra Classic Crew Cab LBZ Duramax / 6spd Allison
SouthCo is offline   Reply With Quote
Old 06-17-2014, 10:21 AM   #3
Senior Member
 
TX_Arvee's Avatar
 
Join Date: May 2012
Location: Pearland, TX
Posts: 514
yes
TX_Arvee is offline   Reply With Quote
Old 06-17-2014, 10:39 AM   #4
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,007
1x, yes. It took about a half-hour to burn off whatever they put on it the first time we used it. Fortunately it was in the driveway and the weather was nice. Haven't had any issues after the first time use.
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 06-17-2014, 10:49 AM   #5
Senior Member
 
Join Date: May 2014
Location: VA
Posts: 394
Guess I got lucky. Never noticed any odd odors or set the smoke alarm off on our first use.
__________________
2005 Dodge Ram 1500 Quad Cab 5.7 HEMI
2̶0̶1̶4̶ ̶J̶a̶y̶ ̶F̶e̶a̶t̶h̶e̶r̶ ̶X̶1̶9̶H̶
howie is offline   Reply With Quote
Old 06-17-2014, 02:17 PM   #6
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 4,190
+1 for yes. Mine created quite the stink, but it was cold outside at the time, so I was able to open all the windows, vents & doors. I let it run 30-45 minutes, and it burned everything off. I've only used once since then though, so perhaps I need to run it again... probably in the winter though... Here in Texas, I don't see our furnace getting all that much use, especially since we keep a small space heater in the trailer.
__________________


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 06-17-2014, 05:33 PM   #7
Senior Member
 
Join Date: Jan 2011
Location: Vienna
Posts: 1,645
I'm on my third Jayco and never had the furnace set off the smoke alarm the first time it was used. Cooking in the kitchen however has been another matter!


__________________

__________________

Joe Hinson
2010 Jayco Quest G2(SOLD)
2014 Jayco Eagle 33.5RETS
2007 Ram 2500 5.9L Cummins(SOLD)
2015 Ram 2500 6.7L Cummins 4WD
:)
namusmc65 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.