Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-06-2014, 08:01 PM   #1
Junior Member
 
Join Date: May 2014
Location: Tallahassee
Posts: 8
New 2014 Whitehawk 27DSRL

Saturday we traded in our 2007 KZ Spree 240 RBS. It was a great trailer - towed it from Florida to Alaska and back in 2010 - and had very few problems over the years. We bought the Whitehawk because of Jayco's reputation for quality and we love the large slide. But we have had some early disappointments.
After a 3 hour PDI we thought we had checked everything, but we made one big mistake. We checked out all the plumbing using the water from the fresh water tank and everything was perfect. The dealer assured us they had already checked out the plumbing using the city water connection and everything was good with it also. A stupid mistake by us.
Saturday night we stayed at a State Park. Set up camp, hooked up the city water connection. We were away from our campsite for about 15 minutes and when we returned our neighbors had turned off our water faucet because water was "cascading" from the top of our trailer. Went inside, the toilet was overflowing with water on the floor(clean water because the toilet has still not been used). The black tank was full, so we dried up the mess and drained the black tank.
We then hooked up a hose to the black water tank flusher connection and found that water did not go into the tank but instead was providing water supply to the kitchen and bath. So we hooked up the hose to the city water connection again and found the water was going directly into the black tank.
Monday morning the dealer worked on the plumbing and got the water going to the right place.
Still kicking myself. Please don't make the mistake we made. The dealer also had to replace a defective front door lock, the top part of the front power jack and a black fender well that had been scratched up.
We think everything is in good shape now and we are happy to be members of the Jayco family.
__________________

jackjan is offline   Reply With Quote
Old 05-06-2014, 08:11 PM   #2
Moderator Emeritus
 
Rustic Eagle's Avatar
 
Join Date: Apr 2011
Location: Michigan
Posts: 7,371
Welcome to JOF

It was unfortunate that you had to find out on your first outing about the plumbing issues...., hopefully going forward your camping experiences will be more enjoyable.

Bob
__________________

__________________

2016 GM 2500HD 6.0L/4.10
2018 Jay Flight 24RBS
2005 Jayco Eagle 278FBS (retired)
1999 Jayco Eagle 246FB (retired)
Reese HP Dual Cam (integrated sway control)
Rustic Eagle is offline   Reply With Quote
Old 05-06-2014, 08:28 PM   #3
Senior Member
 
Join Date: Feb 2013
Location: Dripping Springs
Posts: 153
yes, welcome to the JOF, and hopefully your White Hawk will give you many years of pleasure despite an awkward start.

Just remember that Murphy's Law has an long track record of showing up when you least expect, or want!
__________________
Mike

2014 Chevrolet Silverado 3500HD Crew Cab, long box, Duramax and 3.73, SRW
Equal-i-zer 1k WDH, 2013 White Hawk 27DSRL

Los Madrones, a little slice of Texas hill country heaven
www.losmadrones.com
mikmurphy is offline   Reply With Quote
Old 05-07-2014, 04:44 AM   #4
Senior Member
 
robkelly's Avatar
 
Join Date: Nov 2013
Location: Duxbury
Posts: 4,515
Congratulations and welcome! One more thing to add to the list for our PDI this weekend...
__________________
Rob & Kelly, Bella & Brady (Miniature Schnauzers)
2018 Pinnacle 36KPTS
2017 RAM 3500 SRW CTD/AISIN CC LB
robkelly is offline   Reply With Quote
Old 05-07-2014, 06:00 PM   #5
Junior Member
 
Join Date: May 2014
Location: Tallahassee
Posts: 8
Update on my Whitehawk plumbing problem: The dealer "fixed" my plumbing problem. Now my city water connection and the black water flusher connection work, but, I have a problem I didn't have before. Now, when I put water in the fresh water tank and turn on the water pump, water shoots out the side of the camper from the city water connection. I guess some kind of a problem with valve or backflow diverter? Has anyone else out there had this many plumbing problems with a new Jayco?
jackjan is offline   Reply With Quote
Old 05-14-2014, 08:22 PM   #6
Member
 
kris_12302's Avatar
 
Join Date: Feb 2013
Location: Scotia NY
Posts: 41
Quote:
Originally Posted by jackjan View Post
Update on my Whitehawk plumbing problem: The dealer "fixed" my plumbing problem. Now my city water connection and the black water flusher connection work, but, I have a problem I didn't have before. Now, when I put water in the fresh water tank and turn on the water pump, water shoots out the side of the camper from the city water connection. I guess some kind of a problem with valve or backflow diverter? Has anyone else out there had this many plumbing problems with a new Jayco?
Theres a one way valve on the city water connector on your trailer, take the gasket and screen out of the inlet and u will see the valve, push it in with you finger a few times and try it, sometimes a little piece of dirt will get stuck in the valve
__________________
2013 White Hawk 27dsrl
2011 silverado 2500HD 6.6 Duramax diesel
kris_12302 is offline   Reply With Quote
Old 05-15-2014, 02:33 PM   #7
Junior Member
 
Join Date: May 2014
Location: Tallahassee
Posts: 8
Thanks for the response, Kris. You were exactly right. The valve was actually missing. The local dealer replaced the water connection part (under warranty of course). Everything finally seems to be working correctly. We will be camping this weekend and checking everything out.
jackjan is offline   Reply With Quote
Old 05-17-2014, 07:48 PM   #8
Member
 
kris_12302's Avatar
 
Join Date: Feb 2013
Location: Scotia NY
Posts: 41
Quote:
Originally Posted by jackjan View Post
Thanks for the response, Kris. You were exactly right. The valve was actually missing. The local dealer replaced the water connection part (under warranty of course). Everything finally seems to be working correctly. We will be camping this weekend and checking everything out.
Glad you got it figured out
__________________
2013 White Hawk 27dsrl
2011 silverado 2500HD 6.6 Duramax diesel
kris_12302 is offline   Reply With Quote
Old 05-21-2014, 08:42 PM   #9
Member
 
livelylittlecampers's Avatar
 
Join Date: Apr 2012
Location: Point Pleasant
Posts: 75
Happy Travels!!
__________________

__________________
http://www.livelylittlecampers.com
livelylittlecampers is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.