Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-09-2010, 10:23 PM   #1
Junior Member
 
Join Date: Nov 2010
Posts: 5
class A coach/house batteries not charging

Hi, we own 2003 Jayco Firenza class A gas and really love it. The last trip out we ran across a problem of the house/coach batteries not charging while driving. The only way to keep the system up is to run the generator while traveling. After close examination and research we noticed the "battery control box" under the hood has a burned spot at one terminal and the circuit board has a small burned place. We really think this might be it....but we can't seem to find the box online but I have been told that we could purchase internal parts for the box..... any input? Thanks in advance for your response.
__________________

papajack is offline   Reply With Quote
Old 11-10-2010, 09:29 AM   #2
Senior Member
 
Join Date: Aug 2009
Location: Austin, Texas
Posts: 235
Papajack,

Sounds like you have probably found the problem. If you can determine the manufacturer of the circuit board you should be able to find a replacement on the internet. Here is a link to a discussion of battery box circuit boards on another forum: http://www.rv.net/forum/index.cfm/fu...g/13935498.cfm

Oh, and in the future you might want to post questions like this one on one of the threads devoted to RVs in general or motor homes in particular. This thread is primarily for discussion of problems related to accessing features of this website/forum.

Welcome to the Forum and keep those questions coming.
__________________

__________________
Sam
Emeritus Member of Jayco Owners' Forum
Texas Sam is offline   Reply With Quote
Old 11-11-2010, 11:33 PM   #3
Junior Member
 
Join Date: Nov 2010
Posts: 5
Sorry......I am brand new to forums in general.......I haven't learned my way around yet.....
papajack is offline   Reply With Quote
Old 11-12-2010, 10:43 AM   #4
Site Team
 
Denise's Avatar
 
Join Date: Jul 2009
Location: Mostly the US
Posts: 10,004
Quote:
Originally Posted by papajack View Post
Sorry......I am brand new to forums in general.......I haven't learned my way around yet.....
You're doing great! There is a great group of members here who really look forward to helping folks out with their questions or share their experiences if it might help. When posting to the forum, if you get stuck on something like posting pics, signatures, advatars, etc., someone will step in to give you a hand
__________________
moderator
Denise, DH, grandkids, and two rescue pups
-2016 Jay Flight 29QBS Elite
-2016 Ford F-250 XLT 4x2, 6.2L EFI V8, 4.30 Elec Lock, Heavy duty Alt
Denise is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.