Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-17-2013, 10:53 AM   #11
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,004
You will love the electric tongue jack! I bought an Atwood 3500# which was waaay overkill for our TT - but on the other hand it easily handles the TT and TV while hitched enabling easy setting the WDH bars. The Bride operates the jack while I do the backing :director: Fore/Aft leveling is a snap also.
The manual crank was easy enough but this is that much better.
__________________

__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 06-17-2013, 07:24 PM   #12
Member
 
Join Date: Apr 2013
Posts: 65
Awesome. Ordered a barker 3500 with the 24 inch stroke (Mantelli.) Also bought a new battery today. Looking forward to having it. Does the TT battery get it's charge through the panel inside? There were just the two wires for the battery. From what I understand, it charges off the TV battery when connected. Does the 7 pin send the charge into the panel, then back?
__________________

tmsbandman is offline   Reply With Quote
Old 06-18-2013, 10:43 PM   #13
Senior Member
 
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,303
When you are on shore power the inverter will keep the battery charged. The seven pin from your truck to the trailer will also keep your trailer battery charged while driving. If the engine is off the power most likely is off also.
clutch is offline   Reply With Quote
Old 06-20-2013, 08:54 PM   #14
Member
 
Join Date: Apr 2013
Posts: 65
MAYDAY! Got jack installed, but piston won't move at all. Night light works, so it's obviously getting power. Is there something else? It takes power straight off the battery, so the TV doesn't have to be hooked up, right?
tmsbandman is offline   Reply With Quote
Old 06-20-2013, 09:14 PM   #15
Member
 
Join Date: Apr 2013
Posts: 65
Woohoo! Jayco forum to the rescue. It was a lose wire in the head. Probably came loose in shipping. All is well. Thanks, all, for the help.
__________________

tmsbandman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.