Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-15-2013, 09:37 AM   #1
Junior Member
 
Join Date: May 2013
Posts: 10
No hot water

Hi everyone,
Currently on a trip with our new 28 DSBH and have no hot water. The switch for the LPG in the monitor panel doesn't even light up. I've checked fuses, connections and everything else I can think of. Everything else in the trailer works fine as well the water heater will work if I fire up the generator and use electric element.
I did see a YouTube video on a test to bypass thermal cutoff in hopes that it failed but no luck.

Ideas, experience tests???
__________________

Sticks4Legs is offline   Reply With Quote
Old 06-15-2013, 11:03 AM   #2
Senior Member
 
Join Date: May 2013
Posts: 923
Propane tanks full? Does your stove light up?
__________________

SkyBound is offline   Reply With Quote
Old 06-15-2013, 01:12 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 10
Everything else works, fridge, furnace,etc.
Thought it might be as pressure issue so tried turning them all off but with no luck.
Sticks4Legs is offline   Reply With Quote
Old 06-15-2013, 02:59 PM   #4
Senior Member
 
mcfarmall's Avatar
 
Join Date: Jun 2011
Location: Kalamazoo, West Michigan
Posts: 1,814
No indicator light on the monitor panel switch might mean a no voltage condition to the control board.
__________________
2006 23B Hybrid with 10k round bar WDH
2011 F150 4x4 SCREW Ecoboost, Max Tow, Integrated TBC, 3.73 LS axle, Firestone Ride Rite airbags.
mcfarmall is offline   Reply With Quote
Old 06-16-2013, 08:47 PM   #5
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
My first thought is the wire connection behind the switch panel is not making a good connection. Just an FYI, all three of my switches use a common hot wire. That is why I suspect a bad connection between the switch and the water heater. In reality it could be a bad connection anywhere from the switch to the water heater.
Jagiven is offline   Reply With Quote
Old 06-17-2013, 09:36 AM   #6
Junior Member
 
Join Date: May 2013
Posts: 10
Spoke with my dealer and they are guess-timating that its a bad board. They had me fire up the generator and turn on the electric element switch. Kill the genny with the electric switch still on and then turn on the LPG switch. Fired right up.
__________________

Sticks4Legs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.