Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-15-2018, 06:57 PM   #1
Junior Member
 
Join Date: Sep 2018
Location: Monroe
Posts: 4
Thermostat clicking heat not working

I just bought a 2016 north point 375bfhs. The first time we go to use heat it cycles on and off on electric heat. The heat pump turns on then the thermostat clicks rapidly then turns off the heat. This cycles every 10-15 seconds. If I turn to gas heat everything runs fine. Also when the heat pump is on the gas furnace runs with no ignition of propane, is this normal. The heat pump worked fine last weekend but now itís acting up. Any help is appreciated. What to troubleshoot?
__________________

Dynakin is offline   Reply With Quote
Old 11-17-2018, 06:18 PM   #2
Site Team
 
WinnieView's Avatar
 
Join Date: Nov 2017
Location: Formerly 2008Seneca
Posts: 1,355
You may want to have a dealer test the whole system before the warranty expires.
__________________

__________________
'08 Seneca 35GS- sold
WinnieView is offline   Reply With Quote
Old 11-19-2018, 12:00 PM   #3
Junior Member
 
Join Date: Sep 2018
Location: Monroe
Posts: 4
It's used so no warranty.
Dynakin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.