Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 07-07-2016, 12:22 PM   #1
Member
 
Join Date: Jun 2016
Location: Kingsport
Posts: 60
Water Heater switch

I replaced the water heater switch on my 321 and new switch stays lit all the time. The package says it will light when on, am I doing something wrong or is the switch messed up? The original one just lit up when we flipped it on.
__________________

__________________
Jim & Bee in TN
2007 2500HD Silverado Classic
2016 321RSTS 5er
Gobbledot is offline   Reply With Quote
Old 07-07-2016, 01:40 PM   #2
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
You've got the hot feed and the wire to the water heater reversed.


Swap those two on the back of the switch. All will be fine after that.
__________________

__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 07-07-2016, 02:29 PM   #3
Senior Member
 
Loosenuts's Avatar
 
Join Date: Jun 2016
Location: Kennesaw
Posts: 167
Quote:
Originally Posted by mike837go View Post
You've got the hot feed and the wire to the water heater reversed.


Swap those two on the back of the switch. All will be fine after that.
Yup, what he said. The switch will work but you now have constant power on the side of the switch that the light bulb gets it's power from so it's always on.
__________________
Charles King
Kennesaw, GA
My 28RLS Mods and Observations

TT 2016 Jayco 28RLS
TV 2010 Chevy 2500HD 4x4/Z71 aka The Beast
Loosenuts is offline   Reply With Quote
Old 07-07-2016, 04:14 PM   #4
Member
 
Join Date: Jun 2016
Location: Kingsport
Posts: 60
Quote:
Originally Posted by mike837go View Post
You've got the hot feed and the wire to the water heater reversed.


Swap those two on the back of the switch. All will be fine after that.
Question, I have a White-Green-Red wires and does anyone know which might be the one going to the heater? The switch digram says 3- Ground, 2-Positive, and 1-Load. The ground lug is a different color lug and I placed the White on that, one reason is because it is jumped off of the Electric Water Switch and I placed the Red on the Load lug for the same reason as the white. Would the Ground and Positive jump from the other switch and the load be the odd wire thats not used on the Electric side? I am pretty much a DYI guy but this has my head spinning.
__________________
Jim & Bee in TN
2007 2500HD Silverado Classic
2016 321RSTS 5er
Gobbledot is offline   Reply With Quote
Old 07-07-2016, 06:21 PM   #5
Member
 
Join Date: Jun 2016
Location: Kingsport
Posts: 60
This place is AWESOME!!! Thanks for everyone's help I am back in business. The switch the Dealer gave me to use had the Load and Line wire switched from the OEM one , I remember how I took them off but they went back different. Not a problem as long as I have you all for my back-up, in reality you all are probably more knowledgeable about things more than some dealers. Thanks a gain for all the help!!!
__________________
Jim & Bee in TN
2007 2500HD Silverado Classic
2016 321RSTS 5er
Gobbledot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.