Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-14-2014, 09:03 PM   #1
Senior Member
 
Join Date: Dec 2011
Posts: 428
Towing in cruise control

We have an 05 GMC D/A- Towing in cruise control has presented a problem that tranny specialists have been unable to repair- When we encounter an incline that requires the Allison to downshift, the tranny downshifts into 4th gear and locks up- I must pull off the road, shut the engine off and wait a few minutes before I can restart the engine to continue towing- The "Check engine light" remains on but the tranny operates normally- Anyone out there "been there, done that"? Any info appreciated- THANX in advance- DD
__________________

__________________
Fulltiming since July 1, 1999 currently with a 2005 GMC Sierra 3500 cc drw towing a 2007 Jayco Eagle 341RLQS
Diesel Donnie is offline   Reply With Quote
Old 04-14-2014, 09:25 PM   #2
Senior Member
 
Join Date: Jan 2014
Location: Aurora CO
Posts: 2,336
Wow.... That doesn't sound good at all.... Are you watching temp?
__________________

__________________
Jim & Kim from Colorado

2014 Eagle 30.5 RLS
2015 Dodge 3500HD SRW 6.7L
Click on my profile for Mods and notes
Jmooney is offline   Reply With Quote
Old 04-15-2014, 04:47 PM   #3
Senior Member
 
hammer's Avatar
 
Join Date: Jul 2010
Location: Woodstock, Ontario
Posts: 1,029
Do you have that dmax chipped if you do it sounds like it's going into limp mode
__________________
Dave & Shelley GMC Ext cab Dually 4x4. Duramax Deisel.Allison trans.2010 Jayco Eagle superlite 31.5 RLDS 5er.
hammer is offline   Reply With Quote
Old 04-15-2014, 06:30 PM   #4
Senior Member
 
Join Date: Dec 2011
Posts: 428
There has been no increase in tranny or coolant temp and, yes, we do have an after market program- THANX for your replies- I shall follow up with my tech- DD
__________________
Fulltiming since July 1, 1999 currently with a 2005 GMC Sierra 3500 cc drw towing a 2007 Jayco Eagle 341RLQS
Diesel Donnie is offline   Reply With Quote
Old 04-15-2014, 08:02 PM   #5
Senior Member
 
krsmitty's Avatar
 
Join Date: Feb 2012
Location: Brandon, FL
Posts: 329
There is an "Allison" expert that hangs out on the RVUSA.com forums. Just add your question to the ongoing Allison Transmission question thread. Might be able to help you.

http://www.rvusa.com/forum/vbulletin...hlight=allison
__________________
Ken Smith
2016 Heritage Glen 272RLIS
2017 Dodge Ram 2500 6.7 CTD
krsmitty is offline   Reply With Quote
Old 04-16-2014, 11:02 AM   #6
Senior Member
 
Seann45's Avatar
 
Join Date: Jun 2010
Location: Saskatoon Sask Canada
Posts: 9,701
There is also an Allison engineer that hangs out at the diesel place so maybe you can ask him..
www.dieselplace.com/forum/
__________________
Seann
2004 Chev Silverado Duramax optioned past the max. 2009 Jayco Eagle 308 RLS 765 watts of solar, 6-6 volt batteries (696 amp hour), 2000 watt (4000 surge) whole house inverter.
175 days boondocking in 2017
215/2016, 211/2015, 196/14, 247/13, 193/12

Seann45 is offline   Reply With Quote
Old 04-16-2014, 12:32 PM   #7
Senior Member
 
Tail_gunner's Avatar
 
Join Date: Mar 2013
Location: da U.P.
Posts: 340
I'm willing to bet most Allison knowledgeable people will tell you to go back to your original programming and try towing again. If it still happens after reverting back to OEM programing then you'll know it's a hardware issue and not software.
Tail_gunner is offline   Reply With Quote
Old 04-16-2014, 12:40 PM   #8
Member
 
Join Date: Mar 2014
Location: Johnsonville
Posts: 58
On some Allison's there is an rpm sensor that gets messed up and causes lock/unlock problems. Did you scan for codes?
__________________
Jayco 32bhds

Daytripper is offline   Reply With Quote
Old 04-16-2014, 04:39 PM   #9
Senior Member
 
Join Date: Feb 2011
Location: Gilmer, Texas
Posts: 373
My 03 had a problem once and would only go 1st to 2nd and no further.Dealer replaced an external control module (pretty sure external,no bill for fluids/filter) and all was well.
__________________
S.A.Young
2011 321RLTS
2012 Chevy duramax dually
poohbear is offline   Reply With Quote
Old 04-20-2014, 11:59 PM   #10
Senior Member
 
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,303
Quote:
Originally Posted by Tail_gunner View Post
I'm willing to bet most Allison knowledgeable people will tell you to go back to your original programming and try towing again. If it still happens after reverting back to OEM programing then you'll know it's a hardware issue and not software.

This is the best idea yet.
__________________

__________________
2011 Eagle 330RLTS with just about every option.
2017 Silverado 1500 4x4 5.3 with tow package.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.