Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-11-2014, 04:56 PM   #1
Member
 
Join Date: Oct 2011
Posts: 31
12v water pump

Hello, was winterizing and pump stopped pulling antifreeze, is there any way to determine that it just went bad, that would be my assumption. Just want to make sure i am not missing something else before i buy a new one.

Thx

Mike
winstmk is offline   Reply With Quote
Old 11-12-2014, 11:26 AM   #2
Senior Member
 
bucko's Avatar
 
Join Date: Sep 2014
Location: In a house
Posts: 999
Do you have a multimeter or 12 volt test light? If so, you can check for 12 volts at the waterpumps electrical connection points. If 12 volts are there, then I'd say the pump is bad (could try a rap on it with the butt end of a screwdriver to see if it works again).

If 12 volts are not detected (or if test lamp does not light), check for a blown fuse at your panel.
__________________


2005 Jayco GreyHawk Class C
2007 Ford F150
bucko is offline   Reply With Quote
Old 11-12-2014, 11:37 AM   #3
Senior Member
 
Join Date: Aug 2013
Location: NC
Posts: 974
Was it still running?
__________________
No man has a good enough memory to be a successful liar. Abraham Lincoln

2016 36FBTS Pinnacle
2016 F350, 6.7, 4x4, DRW, long bed
B & W Companion 5th wheel Hitch
eldermike is offline   Reply With Quote
Old 11-12-2014, 12:52 PM   #4
Senior Member
 
ALJO's Avatar
 
Join Date: Oct 2014
Location: Sparwood, BC
Posts: 2,800
Send a message via Skype™ to ALJO
In case you overlooked; Be sure when sucking the pink stuff you have a tap open, otherwise the pump will shutoff after building pressure.
__________________
2014 Ram 1500 CrewCab 4x4 5.7 Hemi 3.92 Rear and Air Lift 1000
2005 Jayco Jay Feather LGT - 29Y GVWR-7000 lbs.
Dexter Axle Lift 4-9/16" - installed with sub-frame.
Pro Series 1200 lbs. WDH with Double Sway Bar.
Champion 3100/2800 watt Inverter/Generator-Onboard Solar Power
ALJO is offline   Reply With Quote
Old 11-13-2014, 06:15 AM   #5
Senior Member
 
bucko's Avatar
 
Join Date: Sep 2014
Location: In a house
Posts: 999
Quote:
Originally Posted by ALJO View Post
In case you overlooked; Be sure when sucking the pink stuff you have a tap open, otherwise the pump will shutoff after building pressure.
Good point; overlooked that!
__________________


2005 Jayco GreyHawk Class C
2007 Ford F150
bucko is offline   Reply With Quote
Old 11-13-2014, 06:17 AM   #6
Senior Member
 
RVhiker's Avatar
 
Join Date: Dec 2010
Posts: 1,643
And it couldn't hurt to double check that the valve to the suction line from the water tank is turned off.
__________________
There's lots of advice and information in forums... sometimes it is correct. For example, all of my posts are made by a political appointee who got the job as a reward for contributions to my diesel bill.

2011 Jayco 28.5RLS; 2021 Chevy Duramax; Pullrite Superglide Hitch

RVhiker is offline   Reply With Quote
Old 11-13-2014, 07:56 AM   #7
Member
 
Join Date: Oct 2011
Posts: 31
pump was bad, power was there just not working

Thx
winstmk is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.