Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-30-2014, 09:21 PM   #1
Member
 
Join Date: Mar 2014
Location: North Central WV
Posts: 82
23B Electrical Help

Brought the new trailer home 2 weeks ago and are all packed up and ready to go for our first trip of the year tomorrow. Over the weekend I removed the dinette drawer mod and boxed the wires in the storage area and now the radio doesn't work!!!!! I didn't puncture any of the wiring, merely built a box around the wires to protect them. Does anyone have any idea what color the radio/TV wires are?
Not even sure if this caused the problem or gremlins just moved in over the past few days. We have tested out both the radio and TV and they were previously working fine.
No radio/TV is frustrating but not a deal breaker for camping, but the beep every few minutes coming from the radio is far more troublesome.

Any help would be greatly appreciated
__________________

WVCamper is offline   Reply With Quote
Old 04-30-2014, 11:00 PM   #2
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
That mod had nothing to do with the radio not working. ThoseWeb wires are only for the exterior lights and trailer braking. If I recall the stove light, fan and sink light are on the same fuse as the radio. Do they work? Have you checked the main fuse panel? You may need to remove the stereo, and check the inline fuse behind it. I do not recall what size it is, but it is a glass one. Or at least it is on our 2012.
__________________

Jagiven is offline   Reply With Quote
Old 05-01-2014, 09:00 AM   #3
Member
 
Join Date: Mar 2014
Location: North Central WV
Posts: 82
Thanks Jagiven I didn't think I could have fouled up any of the wires under the dinette, but thought I would at least throw that out there. Called the dealership and they said to try to replace the fuse and if that does not work then they will order another one and trade me out. I will try the fuse and hopefully that fixes it, the web of wires does not look like something I'm interested in or qualified to deal with!
WVCamper is offline   Reply With Quote
Old 05-01-2014, 09:01 AM   #4
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,011
Do I read that the radio and TV are both not working? Our X23B had a 12V radio and 110V TV. You also mention a beep from the radio. If that's the case it may not be a power problem.
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 05-01-2014, 11:00 AM   #5
Member
 
Join Date: Mar 2014
Location: North Central WV
Posts: 82
Correct and correct RedHorse 1. Neither one is working, the radio/DVD overrides the TV. The TV comes on and may work in TV mode but not when utilizing the DVD player. Yes battery or shore power still beeps. Going to try to disconnect the battery and re-set it.
WVCamper is offline   Reply With Quote
Old 05-01-2014, 11:13 AM   #6
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
Our radio unit was replaced during our PDI, as it would not play a DVD.
Jagiven is offline   Reply With Quote
Old 05-01-2014, 11:28 AM   #7
Member
 
Join Date: Mar 2014
Location: North Central WV
Posts: 82
Unfortunately ours worked then, would have saved me an upcoming 5 hour round trip to drop it off and then another trip to go pick it up
WVCamper is offline   Reply With Quote
Old 05-01-2014, 12:19 PM   #8
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
Call Jayco with your vin number and explain the issue. They may have you try a few things. If you determine you need to replace it. They will send you a new one. It is fairly easy to pull out and replace. It is kind a scary the million wires behind it thou.

To pull it out, pop the bezel and remove for screws and it loose. Then pull it out and take a few pictures, and then pull the wire harnesses off and swap it out to the new one. The job should take about 10 minutes.
Jagiven is offline   Reply With Quote
Old 05-01-2014, 12:26 PM   #9
Member
 
Join Date: Mar 2014
Location: North Central WV
Posts: 82
Very helpful, thank You!
I'll keep you posted
WVCamper is offline   Reply With Quote
Old 05-01-2014, 01:21 PM   #10
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,011
Quote:
Originally Posted by WVCamper View Post
Unfortunately ours worked then, would have saved me an upcoming 5 hour round trip to drop it off and then another trip to go pick it up
Our stereo would turn itself on at random times. I spoke with Jayco and they sent me a new one which I installed and they even paid for me to ship the old one back. Like Jag says, easy swap.
__________________

__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.