Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-02-2013, 04:25 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 1
7 pin plug

Original plug on my 17x was ran over and all wires were broke but the brown and yellow. Hooked up to my Tahoe and the running lights worked. Replaced the 7 pin plug and now none of the lights or electrical brakes work not is the battery being charged. Any ideas would be greatly appreciated!

Ramsey
__________________

RAMSEY SESSIONS is offline   Reply With Quote
Old 05-02-2013, 04:45 PM   #2
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
Click image for larger version

Name:	Trailer Wiring.gif
Views:	35
Size:	9.9 KB
ID:	7545

Hope this helps
__________________

Threebutchers is offline   Reply With Quote
Old 05-02-2013, 08:13 PM   #3
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
Check the fuses in your Tahoe. I jackknifed a trailer a few winters ago. Afterwards one of the turn signals would not work, which I narrowed down to at the 7 pin. The turn signals on the truck worked just fine. I would have never guessed a blown fuse under the hood. Just the one turn signal on the trailer did not work.
Jagiven is offline   Reply With Quote
Old 05-02-2013, 11:35 PM   #4
Junior Member
 
ingie66's Avatar
 
Join Date: Sep 2012
Location: Miami, Canada
Posts: 24
[ATTACH][/ATTACH]
__________________
2012 Nissan Titan Pro 4x
2012 Jayco Jayfeather x17z
ingie66 is offline   Reply With Quote
Old 05-03-2013, 05:58 AM   #5
Senior Member
 
tnchuck100's Avatar
 
Join Date: Jun 2012
Location: Sparta, TN
Posts: 1,174
Quote:
Originally Posted by Threebutchers View Post
Attachment 7545

Hope this helps
Do not use this diagram. It is not correct. Think about it....there is no fog light connection on a travel trailer. The other connections are incorrect as well.

ingie has the correct diagram.
__________________
Chuck - Sparta, TN
2012 Jay Flight 22FB, 2 x Honda EU2000i
2013 GMC Yukon XL Denali AWD

EDUCATION is what you get when you read the fine print.....
EXPERIENCE is what you get when you don't.
tnchuck100 is offline   Reply With Quote
Old 05-03-2013, 06:03 AM   #6
Senior Member
 
RoyBraddy's Avatar
 
Join Date: Sep 2011
Location: King George
Posts: 2,397
Those wires are color for color so hook'em back together. ETRAILER has a repacement 7-way cable with the plug already on it offered in two lengths.

These terminate into a metal junction box under the trailer near the trailer tongue. The newer truck lines are also fused under the hood of the truck it seems. Sounds like you are miswired. When you turn the plug upside down the diagrams get reversed haha...

Etrailer has a nice install video that might be helpful



Also the RV trailers use the BLADE TYPE connectors and plugs - Not the PIN TYPE.



Just my thoughts
Roy Ken
__________________
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA
RETIRED DOD DOAF DON CONTRACTOR Electronics Tech 42YRS

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 05-03-2013, 06:17 AM   #7
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
Quote:
Originally Posted by tnchuck100 View Post
Do not use this diagram. It is not correct. Think about it....there is no fog light connection on a travel trailer. The other connections are incorrect as well.

ingie has the correct diagram.
Are you trying to tell me I downloaded false information off the internet? I'm calling Al Gore....

NO WONDER I had a B%$*H of a time wiring up my new LED TT Replacement Lamps......

Name:  2013-03-27_12-18-24_68.jpg
Views: 64
Size:  3.0 KB
Threebutchers is offline   Reply With Quote
Old 05-03-2013, 06:38 AM   #8
Senior Member
 
RoyBraddy's Avatar
 
Join Date: Sep 2011
Location: King George
Posts: 2,397
AL Gore is certainly the father of the internet. Where did I learn that - The internet of course...
Thanks for the chuckle this morning...

I ordered a cable set from ETRAILER for one of my similar mistakes and got just the right thing... I elected to get a new cable set instead of rewiring a new plug on the end of the cable. I needed a long cable anyway... The wire colors sometimes differs too depending who the cable manf is I guess...

A digital VOM multimeter really helps here...

Roy Ken
__________________

__________________
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA
RETIRED DOD DOAF DON CONTRACTOR Electronics Tech 42YRS

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.