Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-31-2015, 09:23 PM   #1
Junior Member
 
Campermouse's Avatar
 
Join Date: Jun 2015
Location: Gatlinburg
Posts: 7
Lights not working

We have a 2003 Jayco Kiwi 23b. We took it out on our first camping trip last week - great trip, everything worked fine. Plugged it in at the house to take care of some things and all of a sudden the lights stopped working. A/C and all outlets still work but none of the lights work (including the range hood). Checked all 15amp fuses and camper breakers - they're fine. Any suggestions? Thanks for your help!
__________________

Campermouse is offline   Reply With Quote
Old 08-31-2015, 10:27 PM   #2
Senior Member
 
wags999's Avatar
 
Join Date: Jan 2015
Location: Surprise
Posts: 1,499
Lights work off the 12 volt system. Could be as easy as your battery is hooked up wrong, which, will cause the converter to cut out when on shore power. You have two electrical systems in your rig, one for 120 volts and one for 12 volts. Outlets, AC, MW, operate off 120 volts most of the rest off the 12 volt system.
__________________

__________________
2011 Toyota Tundra double cab
2015 27RLS
wags999 is offline   Reply With Quote
Old 09-02-2015, 05:06 AM   #3
Senior Member
 
bucko's Avatar
 
Join Date: Sep 2014
Location: Lake Mary
Posts: 347
Check the fuse (usually a 30 amp) by the 12V battery.
__________________
2015 Jayco Jay Featherlight SLX16XRB (TT)
2007 Ford F150 Tow Vehicle (TV)
bucko is offline   Reply With Quote
Old 09-02-2015, 07:14 AM   #4
Senior Member
 
Join Date: Jan 2011
Location: Vienna
Posts: 1,645
Have you had any luck? What's the update?
__________________

Joe Hinson
2010 Jayco Quest G2(SOLD)
2014 Jayco Eagle 33.5RETS
2007 Ram 2500 5.9L Cummins(SOLD)
2015 Ram 2500 6.7L Cummins 4WD
:)
namusmc65 is offline   Reply With Quote
Old 09-02-2015, 07:14 PM   #5
Junior Member
 
Campermouse's Avatar
 
Join Date: Jun 2015
Location: Gatlinburg
Posts: 7
Thanks for all the suggestions! We discovered the issue. Over the battery there are 3 positive (black) wires tied together with a large wirenut. One of them came loose from the wire nut. Not sure this wirenut on top of the battery is proper - anyone else have this set up?
Campermouse is offline   Reply With Quote
Old 09-02-2015, 07:17 PM   #6
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,056
Finding and fixing this type of trouble gives you confidence that you can handle this camping thing.
Most of the problems we have are relatively simple to fix once you find it.

Good job!
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 09-03-2015, 09:49 AM   #7
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 4,190
Quote:
Originally Posted by Campermouse View Post
Thanks for all the suggestions! We discovered the issue. Over the battery there are 3 positive (black) wires tied together with a large wirenut. One of them came loose from the wire nut. Not sure this wirenut on top of the battery is proper - anyone else have this set up?
Yes. I replaced mine with a waterproof wire nut. I picked up a pack of 4 at Home Depot for less than $4. Not cheap, but cheap enough, and the improvement is certainly worth it to me.

Added: I also secured the wires with some electrical tape before I put the new nut on to help stabilize the bundle and then secured the rest of the wires with nylon wire ties. It's all clean and secure up there now, and that confidence is worth the price of admission.
Camper_bob is offline   Reply With Quote
Old 09-03-2015, 10:09 AM   #8
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,056
Liquid electrical tape can be purchased at most any Auto supply. Just dab it on your wire nut or any made connection, soldered ot with a wire nut.

4 oz. Black Liquid Tape | U.S. Plastic Corp.
__________________

__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.