Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-25-2014, 09:16 PM   #1
Junior Member
 
Join Date: Jun 2014
Location: Mountain Home
Posts: 4
New X17Z owner with a question

Hello all,
We just pulled home our new 2013 X17Z and are really pleased. The dealer was great and showed us everything, and it pulled much better than I expected. But I do have a newbie question for you all, so here goes.

When we got home it was pouring so we took it directly to our storage. When we got there we went in the camper to wait out the rain. I expected the lights and radio to work on battery while we waited, but there was no 12 volt power.

I've read the the pop ups have a shut off that kills the 12 volt when the top is down. Does this camper have something similar that shuts it down when then ends are folded up and locked? Or did they possibly knock something loose on the back of the inverter when they put away the shore line?

I know the battery is charged and the master switch is on.

Thanks, any suggestions would be appreciated.
__________________

Woopig is offline   Reply With Quote
Old 06-25-2014, 09:21 PM   #2
Moderator Emeritus
 
Rustic Eagle's Avatar
 
Join Date: Apr 2011
Location: Michigan
Posts: 7,371
Welcome to JOF

I would confirm that the battery cables are tight, and check the 30amp fuse that is located near the battery. Also check the breaker/fuse box as well for any blown 12v fuses.

I'm not aware of any "shut-off" tied into the F/R fold-outs.

Bob
__________________

__________________

2016 GM 2500HD 6.0L/4.10
2018 Jay Flight 24RBS
2005 Jayco Eagle 278FBS (retired)
1999 Jayco Eagle 246FB (retired)
Reese HP Dual Cam (integrated sway control)
Rustic Eagle is offline   Reply With Quote
Old 06-25-2014, 09:53 PM   #3
Junior Member
 
Join Date: Jun 2014
Location: Mountain Home
Posts: 4
Thanks! I checked the fuses inside but it sounds like there is another 30 amp fuse out by the battery. I'll check that out.
Woopig is offline   Reply With Quote
Old 06-27-2014, 09:57 PM   #4
Junior Member
 
cmcfeters's Avatar
 
Join Date: Mar 2013
Location: Halifax, NS
Posts: 11
If it's not the battery, it's either the fuse at the battery or something tripped or blown at the panel as it will work with ends up.

Enjoy your 17Z!
__________________
Jayco Jay Feather Ultra Lite X17Z
cmcfeters is offline   Reply With Quote
Old 06-30-2014, 08:14 AM   #5
Junior Member
 
Join Date: Jun 2014
Location: Mountain Home
Posts: 4
It was the battery. I charged it up and everything is fine now. Well that and what I thought was the on position on the master switch was really off...... duh.
Woopig is offline   Reply With Quote
Old 06-30-2014, 08:26 AM   #6
Junior Member
 
Join Date: Jun 2014
Location: Southern NY
Posts: 14
Congrats on the new rig. We have a 2010 19H and love it.

The lights, power awning, and radio work with the battery pretty much everything else, fridge, TV, water heater, and AC needs the 120vAC power supply.

Not sure if you can but we also added a relay in my truck's fuse box which charges the battery in the camper when towing. Lots of neat solar charging options now too.
mikeG is offline   Reply With Quote
Old 06-30-2014, 08:56 AM   #7
Junior Member
 
Join Date: Jun 2014
Location: Mountain Home
Posts: 4
We've had it set up since Friday night at our fireworks tent. Been running the lights, radio and fridge with nothing but 12 volt and lp. It'll be interesting to see how much propane the fridge uses.

It's been working great though. Our battery was fully charged and finally went down to 50% last night so I put little 8 amp charger on it to bring it back up. The charger has a maintenance setting that adjusts the amperage so I guess I could leave it on there if I wanted.

Where we have the tent, the only access to power is to hook up about 200 feet of extension cord, so battery is our only option. No way I'd hook the cord directly to the camper.
__________________

Woopig is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.