Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 07-16-2018, 11:23 AM   #1
Member
 
Join Date: Apr 2018
Location: Henrietta
Posts: 42
Possible refrigerator issue

2018 x17z. We got home yesterday from a 3 day camping trip. The entire time we were gone the fridge was fine. Get home, open up the camper, hose it off, let it dry, close it up, while i'm closing up the bunks I notice the hose that releases the moisture from the fridge is leaking a lot, there was a pretty good size puddle on the ground, we've never had that before after camping. The fridge was still on as we had food and drinks in it, the camper was connected to the house electric. I go into the camper and check the fridge, it was not very cold, all the drinks had condensation on them and some of the food was starting to thaw. From what I could tell the fridge was running, I could hear it but it wasn't getting very cold. I shut it down, and removed everything but i'm a bit worried something is wrong with the fridge. The fridge has been on pretty much nonstop since June 22nd as we've had trip after trip since then and didn't see a reason to shut it down. The fridge as been on electric unless it was in transit to a site or our house. The camper is level in my driveway so i'm not sure what else to try. If anyone has any ideas please let me know. I'm going to turn it back on when I get home from work tonight and see its any better, if not I'll be calling the dealership.
__________________

JE78 is offline   Reply With Quote
Old 07-16-2018, 11:42 AM   #2
Senior Member
 
oldmanAZ's Avatar
 
Join Date: Dec 2014
Location: AZ
Posts: 8,681
Quote:
Originally Posted by JE78 View Post
snip...

The fridge was still on as we had food and drinks in it, the camper was connected to the house electric. I go into the camper and check the fridge, it was not very cold, all the drinks had condensation on them and some of the food was starting to thaw. From what I could tell the fridge was running, I could hear it but it wasn't getting very cold.
...snip

A couple of things...
- I don't recall hearing anything from our fridge when it is on electric.
- Was the breaker switched off so the fridge wasn't really on?
- Check the seals and be sure the the door(s) close tight. Moisture from the outside gets in through a seal problem or the door being opened.


Hope it helps.
__________________

__________________
Sherm & Terry w/rescue Eydie (min Schnauzer)
2015 Jay Flight 27RLS (Nights Camped: 102 '15, 90 '16, 80 '17, 161 '18 so far)
2006 Ford F350 6.0 PSD, Lariat, 4WD, CC, LB, SRW, auto., Camper pkg.
oldmanAZ is offline   Reply With Quote
Old 07-16-2018, 11:52 AM   #3
Member
 
Join Date: Apr 2018
Location: Henrietta
Posts: 42
Quote:
Originally Posted by oldmanAZ View Post
A couple of things...
- I don't recall hearing anything from our fridge when it is on electric.
- Was the breaker switched off so the fridge wasn't really on?
- Check the seals and be sure the the door(s) close tight. Moisture from the outside gets in through a seal problem or the door being opened.


Hope it helps.
I did check the breaker but not the fuse but since the lights and everything are the same fuse/breaker and the lights were working I'm going to assume the fuse was good. I didn't hear anything from the inside of the fridge but when outside, there's a plastic guard that you can take off that's the back of the fridge and I could hear it running there. Doors seem fine, there's a very loud click when it's shut, the camper is only a few months old so not much wear on it.
JE78 is offline   Reply With Quote
Old 07-16-2018, 01:51 PM   #4
Senior Member
 
hoppers4's Avatar
 
Join Date: Mar 2015
Location: Port Orchard
Posts: 1,413
Every couple of days the fridge shuts down to defrost. I turn my fridge off and on every day to prevent the defrost cycle. If you just turn it back on now, it'll work.
__________________
Don
hoppers4 is offline   Reply With Quote
Old 07-16-2018, 05:47 PM   #5
Member
 
Join Date: Nov 2016
Location: Vernon
Posts: 60
I had something similar. Fridge was working great all week then not real cold and a lot of frost developed in freezer. A slightly long wine bottle had been put on the bottom shelf causing the bottom half of the door not seal well.
jimovernon is offline   Reply With Quote
Old 07-16-2018, 06:53 PM   #6
Member
 
nisbitch's Avatar
 
Join Date: Jul 2016
Location: Lambton County, Ontario
Posts: 51
I had the same problem. DW had too much food in the fridge that caused the bottom part of the door to not seal properly. A little Tetris with the food and the door seals correctly. Thatís where Iíd start.
__________________
2017 Jay Flight 27BHS
2013 Ram 1500 Sport CC 3.92
nisbitch is offline   Reply With Quote
Old 07-16-2018, 07:58 PM   #7
Senior Member
 
2edgesword's Avatar
 
Join Date: Jul 2011
Location: Long Island, NY
Posts: 697
Quote:
Originally Posted by nisbitch View Post
I had the same problem. DW had too much food in the fridge that caused the bottom part of the door to not seal properly. A little Tetris with the food and the door seals correctly. Thatís where Iíd start.
Your wife must pack the frig like my wife does. I ask her at the end of every trip why I'm carrying so much food back into the house.
__________________

2018 Jayco 28RLS
2012 F-250 6.2L 3.73
Equalizer Hitch
Yamaha 2400ISHC
2edgesword is offline   Reply With Quote
Old 07-16-2018, 08:36 PM   #8
Member
 
Join Date: Apr 2018
Location: Henrietta
Posts: 42
Quote:
Originally Posted by hoppers4 View Post
Every couple of days the fridge shuts down to defrost. I turn my fridge off and on every day to prevent the defrost cycle. If you just turn it back on now, it'll work.
Thanks Don! I hope that's what its doing but like I said, I've never seen it do it and the fridge has been on for almost a month until yesterday.

I don't believe it was something keeping the door open. The fridge wasn't that full. I guess something could've been keeping it open but I checked and all looked good.
JE78 is offline   Reply With Quote
Old 07-16-2018, 09:28 PM   #9
Member
 
Join Date: Apr 2018
Location: Henrietta
Posts: 42
We'll I just went and checked it. It's been on since this morning and it's barely cold and it's still defrosting. There's a few things in the freezer and 2 bottles of water barely cold that my finger prints don't show. Starting to get worried the fridge is going bad. I flipped a few brakers and pulled the power from the house and plugged it back in. I'll check in the morning and see if there's any improvement.
JE78 is offline   Reply With Quote
Old 07-16-2018, 10:03 PM   #10
Member
 
Join Date: Jul 2013
Posts: 97
Check the vent stack and make sure the fins are cleaned if debris. Mine had a lot of cotton stuck to the cooking fins. Also add some fans. Makes a huge difference.
__________________

tcanthonyii is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.