Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-22-2015, 10:23 AM   #1
Member
 
Join Date: Dec 2014
Location: Austin
Posts: 73
X17Z: first broken part

We just had our first piece/part break on our one year old 2014 X17Z. We have used the camper five times in the last year. The part was one "hinge/lock" on the outside oven vent. The vent appeared to be installed poorly from the beginning. One hinge worked well, but one was too hard to open/close. It eventually broke off (plastic hinge lock). Not worth the trouble to have it fixed under warranty. One hinge is enough to keep the vent closed when not in use.

Anyone else had failures on the their X17Z?
__________________

ashmanbrian is offline   Reply With Quote
Old 09-22-2015, 10:52 AM   #2
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
Running a different trailer. But those locks are an issue for all Jaycos...


I haven't latched the vent since I brought it home from the dealer.
__________________

__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 09-22-2015, 07:01 PM   #3
Senior Member
 
Join Date: Sep 2014
Location: Blaine
Posts: 146
We have a 08 X17C and ours is the same way
rabalin is offline   Reply With Quote
Old 09-23-2015, 10:42 AM   #4
Senior Member
 
Allamuchy Joe's Avatar
 
Join Date: Aug 2012
Location: Newton, NJ
Posts: 174
Same thing happened on our X23B last summer. We had to bring the trailer in for other warranty work last year, so we had the dealer replace it. This one works better, but is still pretty hard to open.
__________________
2014 Ram 1500 Quad Cab Big Horn
2015 Jayco X23B
Allamuchy Joe is offline   Reply With Quote
Old 09-23-2015, 11:04 AM   #5
Senior Member
 
Join Date: May 2013
Location: SE Wisconsin
Posts: 2,057
This happened on our old '03 Kiwi 17a after about 5 years. One clip, then the other clip. A replacement vent was about $6, plus the butyl putty. 30 minutes to change it, most of that time spent cleaning the old putty off.
__________________
Chuck
2013 Jayco Jayfeather X20 E, 2008 GMC Sierra 1500 Crew Cab Z71 SLE
DocBrown is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.