Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-15-2014, 02:47 PM   #1
Junior Member
 
Join Date: Aug 2014
Location: Glen Rose
Posts: 3
110 volt electricity not working

Our 110 volt power just went out on our 2013 jay flight rv. We reset the breaks in the box under the refrigerator. Also reset the 50 amp breaker on the post. It is still not working. Please looking for any other ideas to get our 110 volt power to work. It's hot in Tx today!


Thanks
__________________

Minnow312 is offline   Reply With Quote
Old 09-15-2014, 02:52 PM   #2
Senior Member
 
Join Date: Aug 2013
Location: NC
Posts: 973
Were any of the breakers tripped?
__________________

__________________
No man has a good enough memory to be a successful liar. Abraham Lincoln

2016 36FBTS Pinnacle
2016 F350, 6.7, 4x4, DRW, long bed
B & W Companion 5th wheel Hitch
eldermike is offline   Reply With Quote
Old 09-15-2014, 03:10 PM   #3
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,045
Did the end of your power cord melt around the prongs. May have disintegrated internally.
__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 09-15-2014, 03:25 PM   #4
Junior Member
 
Join Date: Aug 2014
Location: Glen Rose
Posts: 3
None of the breakers were tripped. Power cord ok
Minnow312 is offline   Reply With Quote
Old 09-15-2014, 03:28 PM   #5
Lost in the Woods
 
Join Date: Jun 2014
Location: Woodstock
Posts: 1,128
Not to state something obvious but have you had someone determine there is power at the pedestal?
nbhybrid is offline   Reply With Quote
Old 09-15-2014, 03:33 PM   #6
Junior Member
 
Join Date: Aug 2014
Location: Glen Rose
Posts: 3
It was the camp site breaker box. Husband didn't flip it hard enough at the box. So $95 later the mobile rv repair guy came out & flipped the breaker in the box . UGH! !!
Minnow312 is offline   Reply With Quote
Old 09-15-2014, 03:33 PM   #7
Senior Member
 
3'senough's Avatar
 
Join Date: Sep 2010
Location: New York
Posts: 2,072
Quote:
Originally Posted by Minnow312 View Post
Our 110 volt power just went out on our 2013 jay flight rv. We reset the breaks in the box under the refrigerator. Also reset the 50 amp breaker on the post. It is still not working. Please looking for any other ideas to get our 110 volt power to work. It's hot in Tx today!


Thanks
Did you check with the CG maintenance yet to verify that the post is active? After they confirm then I would proceed with all the breakers off then turn on only the main and an outlet. Go one by one and confirm power to each one saving the AC for last.
__________________

__________________

2014 375 BHFS Eagle Premier
2014 Ram 3500 Longhorn DRW CC
6.7 CTD, Aisin, 4.10's
Yamaha EF3000iSEB
3'senough is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.