Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 07-06-2016, 09:49 PM   #11
Senior Member
 
shadester's Avatar
 
Join Date: Mar 2016
Location: Upstate N.Y.
Posts: 326
The manual for your model indicates a Bad battery = low output. No Battery, probably means no output unless you jump it ?. I know I had a micro processed unit like this a few years back. If my battery was below a certain voltage it wouldn't turn on. Also when you store, I'd disconnect battery if you don't have the switch disconnect. And make sure battery is at acceptable voltage prior to use.
__________________

shadester is online now   Reply With Quote
Old 07-13-2016, 02:55 PM   #12
Member
 
Join Date: Oct 2012
Posts: 36
Is it possible that the "empty" leads for the battery were somehow grounding out and the charger/controller stopped sending power to the 12V system because it sensed a short?
__________________

DadRich is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.