Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-18-2015, 11:21 PM   #1
Senior Member
 
Murff's Avatar
 
Join Date: Mar 2015
Location: Seattle area
Posts: 2,116
Atwood Range Will Not Light

On the road with new 20MRB. Stopped for the night & SWMBO started dinner but the stove burners would not light. Checked propane tanks and have plenty of fuel. Started hot water heater on propane and it fired just perfect.

Just seems to be no propane getting to the stove. Have a request in at nearest Jayco dealer in the morning. Anyone here havethis happen to them?

Thanks in advance.

Murff
__________________

__________________
Murff
2015 White Hawk 20MRB (It's last year)
2011 F150 Non EcoBoost (5.0)
Andersen Hitch
Murff is offline   Reply With Quote
Old 06-19-2015, 06:40 AM   #2
Senior Member
 
Join Date: Jan 2011
Location: Vienna
Posts: 1,645
Check underneath the unit to make sure the propane hose is not kinked. There is a junction box where the propane lines split off to the various devices. Ours had a kink in one line and would not let fuel flow. Had to reposition junction box.
__________________

__________________

Joe Hinson
2010 Jayco Quest G2(SOLD)
2014 Jayco Eagle 33.5RETS
2007 Ram 2500 5.9L Cummins(SOLD)
2015 Ram 2500 6.7L Cummins 4WD
:)
namusmc65 is offline   Reply With Quote
Old 06-19-2015, 06:45 AM   #3
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
^^^X2^^^ Had the fridge shortchanged one day. Moved the hose guide to free up some line.
__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 06-19-2015, 08:22 AM   #4
Senior Member
 
Murff's Avatar
 
Join Date: Mar 2015
Location: Seattle area
Posts: 2,116
Joe & Mike,

Thank you for the suggestions.

I sent a service request in to Bish RV, they have several stores in Idaho. The general manager replied to my email last night just before midnight asking me to bring the rig in this morning. Great customer service.

Murff
__________________
Murff
2015 White Hawk 20MRB (It's last year)
2011 F150 Non EcoBoost (5.0)
Andersen Hitch
Murff is offline   Reply With Quote
Old 06-19-2015, 10:19 PM   #5
Senior Member
 
Murff's Avatar
 
Join Date: Mar 2015
Location: Seattle area
Posts: 2,116
Got up this A.M. and drove to Bish's RV. Corey Harward was calling me as I was walking in the door of their service department. Corey took his time to listen to what the problem was with the range. He then went in the trailer and turned on one of the burners and hit the piezo igniter. Sure enough, just like Murphy's Law in reverse, the burner lit up just as perfect as could be. He then checked all the burners, and all functioned well.

He inspected under the burner cover and crawled under the trailer and found nothing irregular. Corey said the obvious, it was hard to diagnose something that is working correctly. He charged us nothing for his time.

I cannot speak for all Jayco dealers, but I feel safe that if you are in Idaho and have a problem with your rig, do not hesitate to call one of Bish RVs locations. If each location's general manager is like the Pocatello's John Myer, you will be in good hands!

Murff
__________________
Murff
2015 White Hawk 20MRB (It's last year)
2011 F150 Non EcoBoost (5.0)
Andersen Hitch
Murff is offline   Reply With Quote
Old 06-20-2015, 08:41 AM   #6
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,007
Sounds like an excellent dealership. Good luck with the stove, hop in' it was a 1 time glitch.
__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Old 06-20-2015, 09:37 AM   #7
Senior Member
 
Join Date: May 2015
Location: Kunkletown PA
Posts: 115
Glad it works. Stinks that it fixed itself at the dealer. I hate it when that happens. DW called me in to "fix" the stove because it wasn't lighting. Lighter wasn't close enough to the burner.
__________________
2008 Toyota Tacoma Off Road
2015 264BHW
Angus is offline   Reply With Quote
Old 06-22-2015, 08:57 AM   #8
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
Next time the thing fails to light, use a match to try and light it.


If air or stale gas is in the line, you can see the match's flame pushed by the non-flammable contents of the line.


If the line is kinked or the safety in the tanks' valve's kicked in (you did open the valves slowly, didn't you?) there will be no disruption in the match's flame.


If the damn thing lights, then the piezo ignition system is faulty; Check the wiring for breaks and chaffing to ground.
__________________

__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.