Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-11-2015, 09:44 AM   #1
Junior Member
 
Join Date: Aug 2015
Location: Lloydminster
Posts: 2
Awning LEDs not working

Hi!

This is on a 2014 314BHDS, not that it matters as I'm guessing the awning LEDs are all the same on the Jaycos

Anyway, moved the trailer to a new site (LEDs were working prior to move). Got set up and at night went to turn on the lights, no go. All other lights and plugs seem fine. No breakers tripped and all fuses are good.

It's either the switch or the transformer. Anyone know where the transformer is? Can't seem to locate a good schematic anywhere. Didn't bring my multimeter, but have a buddy coming out with one later.

It's under warranty, but we're gone for another 2 weeks and no outside light sucks. Lol
__________________

TrevorG is offline   Reply With Quote
Old 08-11-2015, 10:43 AM   #2
Senior Member
 
maromeo's Avatar
 
Join Date: Sep 2010
Location: Scottsdale, AZ
Posts: 792
We have had the 3rd strand installed just a month ago. While it was at the dealer under warranty we had them install an outside light since one was not installed. It can be a backup when the light strip goes bad. It cost the price of the light and 1/2 hour shop rate. It was a great decision.
__________________

__________________
Joe and Mary Anne
1 18 yr old DD
2014 Ram 2500 Diesel Laramie Mega Cab 4 X 4
2011 Jayco Jay Flight 26RLS-Sold
2014 Jayco Eagle 298 RLDS
maromeo is offline   Reply With Quote
Old 08-11-2015, 11:16 AM   #3
Senior Member
 
THE MEEKER's Avatar
 
Join Date: Apr 2015
Location: Western New York
Posts: 125
I purchased a Jayflight 27RLS this past April and the LED light strip failed just a few days after delivery. I had a new set installed under warranty. Now this past weekend, the second set has failed as only 1/4 of the length works.

Many posts on this matter here. These LED light strips are cheap junk.

I will take them down all together as they are way too bright and attract bugs.
__________________
2015 Jayco Jayflight 27RLS
2012 Ford F-150
2001 Fleetwood Terry 28x
1996 Viking Pop-up
1979 Coleman 8 man cabin tent
1967 G.I Joe (hasbro) canvas pup tent
THE MEEKER is offline   Reply With Quote
Old 08-11-2015, 11:43 AM   #4
Senior Member
 
Join Date: May 2013
Posts: 113
You might want to check the connection where the wire connects to the led strip.Ours wire was stretched so tight the connection pulled apart.
__________________
2014 321RLTS Eagle Premier
2013 3500 CC DMAX
jimandcarol is offline   Reply With Quote
Old 08-11-2015, 06:15 PM   #5
Junior Member
 
Join Date: Aug 2015
Location: Lloydminster
Posts: 2
Thanks for the replies. I found the problem shortly after I posted. The dollar store marettes they use are terrible (I've swapped all of mine to good ones now). The connection where the awning wires come in to the trailer (inside the front storage area) was disconnected as the cheap marette fell off. Good to go now
TrevorG is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.