Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-30-2016, 01:13 PM   #1
Member
 
Rlawyo's Avatar
 
Join Date: Sep 2015
Location: Northern Wyoming
Posts: 50
Blowing fuse!

Never had a problem last summer, but this weekend I blew two 30 amp fuses while raising tongue jack. I had to use a 20 amp fuse to get jack down, because I was out of 30's.

I think the solution is to not run the jack to the stop!

Any ideas?

Thanks.!
__________________

__________________
2012 Tundra-5.7
2016 Jayco JayFeather 23 RSLW
Rlawyo is offline   Reply With Quote
Old 05-30-2016, 02:12 PM   #2
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
Lots of people replace the fuse with reseting circuit breaker fuses.
__________________

Jagiven is offline   Reply With Quote
Old 05-30-2016, 02:27 PM   #3
Senior Member
 
Nukeneck's Avatar
 
Join Date: Dec 2015
Location: Northern Nevada
Posts: 267
That just recently happened with me. I'm a bit baffled myself but I replaced the fuse and it hasn't happened since. Curious if any electrical gurus have an answer
__________________
2015 Jayco White Hawk 28dsbh
2014 Ford F150 4x4 w/Ecoboost
H/D tow package

2005 Forest River Rockwood 2601 (Sold)
2011 Ford Expedition XLT (Sold)
2008 Jeep Wrangler (Just for fun!)
Nukeneck is offline   Reply With Quote
Old 05-30-2016, 02:32 PM   #4
Senior Member
 
oldmanAZ's Avatar
 
Join Date: Dec 2014
Location: AZ
Posts: 7,063
After I blew the last 30amp fuse I had, I ordered a bag of 30, 30amp fuses for $4.88 on Amazon. No, I won't need all of them, but they were cheap.

Plus, I'll have one to give if a camper next to me blows his! It might be you.
__________________
Sherm & Terry w/rescues Eydie (min Schnauzer) Steve RIP (std Poodle)
2015 Jay Flight 27RLS (Camped: 102 nights '15, 90 nights '16, 70 nights '17 so far)
2006 Ford F350 6.0 PSD, Lariat, 4WD, CC, LB, SRW, auto., Camper pkg.
oldmanAZ is online now   Reply With Quote
Old 05-30-2016, 04:13 PM   #5
Senior Member
 
Camping Couple's Avatar
 
Join Date: Aug 2012
Location: Kalamazoo
Posts: 726
Quote:
Originally Posted by Rlawyo View Post
Never had a problem last summer, but this weekend I blew two 30 amp fuses while raising tongue jack. I had to use a 20 amp fuse to get jack down, because I was out of 30's.

I think the solution is to not run the jack to the stop!

Any ideas?

Thanks.!
So this happened to me today. I was installing a fastway flip foot and while going up and down without loading up the Jack, the fuse just blew. I have no explanation. I have a Barker VIP 3500 Tongue Jack and that also has a 30 amp fuse. It is a slow blow fuse though. I think I'm going to take Jagiven's advice and switch to a 30 amp breaker. I think exercising my tongue Jack up and down while installing the flip foot may have heated the fuse and blew it. Funny thing is, the 30 amp fuse didn't look blown. I had to put a meter to it and it was open.
__________________

2015 Jayco 24FBS Elite Jay Flight
2013 Chevrolet Silverado 2500HD 4X4 6.0L 3.73 Axle
HD Trailering Package with Integrated Brake Controller
Equal-i-zer Hitch 10k/1000
Camping Couple is offline   Reply With Quote
Old 05-30-2016, 05:19 PM   #6
Member
 
Rlawyo's Avatar
 
Join Date: Sep 2015
Location: Northern Wyoming
Posts: 50
I like the idea of circuit breaker,. My fuses were $1 each. So a trip to a salvage yard is in order.
__________________
2012 Tundra-5.7
2016 Jayco JayFeather 23 RSLW
Rlawyo is offline   Reply With Quote
Old 05-30-2016, 06:42 PM   #7
Junior Member
 
Join Date: May 2016
Location: Kent
Posts: 1
I have had the same problem. Once with the tongue jack and once with my rear slide it's the 30 amp fuse just under the battery tray. Took me forever to find that fuse.
Jterrana is offline   Reply With Quote
Old 05-30-2016, 07:26 PM   #8
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,059
Some of those self resetting breakers have a time delay on them so be patient!
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 05-30-2016, 08:43 PM   #9
Member
 
Rlawyo's Avatar
 
Join Date: Sep 2015
Location: Northern Wyoming
Posts: 50
Same for me, did the panel check, then thought, there has to be one near the battery. Yup!
__________________
2012 Tundra-5.7
2016 Jayco JayFeather 23 RSLW
Rlawyo is offline   Reply With Quote
Old 05-30-2016, 09:45 PM   #10
Senior Member
 
Murff's Avatar
 
Join Date: Mar 2015
Location: Seattle area
Posts: 2,116
Here is where I bought mine:

Del City - Electrical Supplies & Professional Grade Wiring Products

Also bought weather cover for it.

Murff
__________________

__________________
Murff
2015 White Hawk 20MRB (It's last year)
2011 F150 Non EcoBoost (5.0)
Andersen Hitch
Murff is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.