Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-11-2015, 05:30 PM   #1
Junior Member
 
Join Date: May 2015
Location: georgetown
Posts: 7
No Power

I have a 2005 Jayco Jay Flight 5th Wheel. My brother and his family wanted to use it for the weekend at a BBQ cook off. My brother had the camper running off a generator (unknown further) and it allegedly worked fine the entire time. Well, I went to pick it up yesterday and had no power. I assumed the battery was dead so and plugged it into the truck in order to retract the slide out. No luck, even when plugged into the truck I have no power. The only thing that is working on the trailer are the exterior running lights. I have checked the main breakers and fuses that are located in the panel under the stove as well as the inline fuse on the battery (battery is 1 year old). I have zero power. Any help would be greatly appreciated.
__________________

jcox is offline   Reply With Quote
Old 05-11-2015, 07:36 PM   #2
Senior Member
 
Bsikes's Avatar
 
Join Date: Dec 2014
Location: Midlothian, TX
Posts: 257
Check to see if the ground post to the trailer frame is connected. Had a similar issue where my ground screw broke off the tongue. Had no power for anything.
__________________

__________________
Brian, Michelle, 2 boys and Sadie Mae the beagle
2010 Toyota Tundra Crew Max 5.7L
2015 Jayco White Hawk 33BHBS Summit Edition, Glacier Package
Equil-I-Zer WDH
Bsikes is offline   Reply With Quote
Old 05-11-2015, 08:00 PM   #3
Junior Member
 
Join Date: May 2015
Location: georgetown
Posts: 7
Will do, thank you.
jcox is offline   Reply With Quote
Old 05-12-2015, 07:31 AM   #4
Senior Member
 
Seann45's Avatar
 
Join Date: Jun 2010
Location: Saskatoon Sask Canada
Posts: 9,701
Did you check the fuse at the battery?
__________________
Seann
2004 Chev Silverado Duramax optioned past the max. 2009 Jayco Eagle 308 RLS 765 watts of solar, 6-6 volt batteries (696 amp hour), 2000 watt (4000 surge) whole house inverter.
175 days boondocking in 2017
215/2016, 211/2015, 196/14, 247/13, 193/12

Seann45 is offline   Reply With Quote
Old 05-12-2015, 09:06 AM   #5
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
Also, just to be sure, throw a voltmeter on the battery directly.

Do any 12v items work when the trailer is plugged in to 110VAC?
mike837go is offline   Reply With Quote
Old 05-12-2015, 09:13 AM   #6
Junior Member
 
Join Date: May 2015
Location: georgetown
Posts: 7
Yes, the fuse is good.
jcox is offline   Reply With Quote
Old 05-12-2015, 09:17 AM   #7
Senior Member
 
Join Date: Jan 2014
Location: Aurora CO
Posts: 2,336
Quote:
Originally Posted by Bsikes View Post
Check to see if the ground post to the trailer frame is connected. Had a similar issue where my ground screw broke off the tongue. Had no power for anything.

Fuses are good and even connected to the truck - you have no DC power - the ground issued suggested above may be an issue
__________________
Jim & Kim from Colorado

2014 Eagle 30.5 RLS
2015 Dodge 3500HD SRW 6.7L
Click on my profile for Mods and notes
Jmooney is offline   Reply With Quote
Old 05-12-2015, 09:17 AM   #8
Junior Member
 
Join Date: May 2015
Location: georgetown
Posts: 7
Mike837go

The generator was gone when i arrived and there is no electric in that area, so i do not know if 12v was/ will work with 110. According to my brother it was working. I will try the voltmeter.
jcox is offline   Reply With Quote
Old 05-12-2015, 09:19 AM   #9
Junior Member
 
Join Date: May 2015
Location: georgetown
Posts: 7
Cool, i worked 16 hours yesterday and didnt get to check it. I will check it this evening. Thanks for the help.....
jcox is offline   Reply With Quote
Old 05-12-2015, 09:22 AM   #10
Senior Member
 
Join Date: Dec 2014
Location: Tekamah
Posts: 103
Quote:
Originally Posted by Bsikes View Post
Check to see if the ground post to the trailer frame is connected. Had a similar issue where my ground screw broke off the tongue. Had no power for anything.
We had a similar issue, and there was a ground underneath the power box on frame.
__________________

Pegsmi98 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.