Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-21-2013, 06:31 PM   #1
Junior Member
 
Join Date: Aug 2013
Posts: 4
Radio problem

I have a 2001 Jayco Designer 5th wheel. The radio does not want to turn on. It will show the time on the display but the unit will not turn on. Anybody have any ideas about what could be the problem?
__________________

Firefighter87 is offline   Reply With Quote
Old 08-22-2013, 05:18 PM   #2
Senior Member
 
Cosmik Debris's Avatar
 
Join Date: Aug 2013
Location: Missoula, Montana
Posts: 554
Is it the Jensen? It being 12 years old, I didn't want to assume.
__________________

Cosmik Debris is offline   Reply With Quote
Old 08-23-2013, 01:23 PM   #3
Senior Member
 
Join Date: May 2013
Location: SE Wisconsin
Posts: 2,057
I doubt its the Jensen. There was another brand back then that was used a lot, but I can't recall the name. In any case, I think its too old to spend a lot of time troubleshooting. You can get far better quality with a $100 head unit for a car. Another $30 for the mounting kit and you'll be all set.
__________________
Chuck
2013 Jayco Jayfeather X20 E, 2008 GMC Sierra 1500 Crew Cab Z71 SLE
DocBrown is offline   Reply With Quote
Old 08-24-2013, 11:17 AM   #4
Junior Member
 
Join Date: Aug 2013
Posts: 4
Its not a Jenson. Thats what I thought I would have to do is just replace it. Might be better to upgrade anyway. Thank you for your help.
Firefighter87 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.