Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-13-2012, 08:09 PM   #21
Senior Member
 
Join Date: Jan 2012
Location: Lander, Wyoming
Posts: 588
Larry, glad to see that your might be fixed. The original problem with which I started this thread was, supposedly, faulty motors on the Schwintek slide system. They sent new motors with instructions on how to replace. We got a call two days ago that the trailer was ready to go so got up this morning to drive the 150 miles to the dealer to pick it up. When we got into the FW to test the bedroom slide, nothing happened. The tech, the salesman and the shop manager were very surprised but did spend about three hours trying to fix the problem, spending over 1 1/2 hours on the phone with Lippert. They even went so far as to take the motor controller out of another similar trailer withe the same slide. Put it in, and same thing, nothing. Supposed to overnight Monday so they can try and fix it on Tuesday and the dealer said they would deliver it to me since we've made two trips down there to get this fixed. With the price of diesel, it takes about $100 for us to go down there and back, one-way with the FW. Hope they get it right this time. I am going to start a conversation with Lippert to see if they would be willing to do anything about the cost of the trips, although I would guess they will not be real enthusiastic about it. i know it's not as important as Larry's deal, but thought I would bring it up in my thread, anyway.
__________________

jal0710 is offline   Reply With Quote
Old 04-13-2012, 08:56 PM   #22
Senior Member
 
Larry G.'s Avatar
 
Join Date: Dec 2011
Location: Reno (home base) Winter Eloy, AZ
Posts: 949
Quote:
Originally Posted by jal0710 View Post
Larry, glad to see that your might be fixed. The original problem with which I started this thread was, supposedly, faulty motors on the Schwintek slide system. They sent new motors with instructions on how to replace. We got a call two days ago that the trailer was ready to go so got up this morning to drive the 150 miles to the dealer to pick it up. When we got into the FW to test the bedroom slide, nothing happened. The tech, the salesman and the shop manager were very surprised but did spend about three hours trying to fix the problem, spending over 1 1/2 hours on the phone with Lippert. They even went so far as to take the motor controller out of another similar trailer withe the same slide. Put it in, and same thing, nothing. Supposed to overnight Monday so they can try and fix it on Tuesday and the dealer said they would deliver it to me since we've made two trips down there to get this fixed. With the price of diesel, it takes about $100 for us to go down there and back, one-way with the FW. Hope they get it right this time. I am going to start a conversation with Lippert to see if they would be willing to do anything about the cost of the trips, although I would guess they will not be real enthusiastic about it. i know it's not as important as Larry's deal, but thought I would bring it up in my thread, anyway.
It sure IS important!!

Surprised that the dealer did not verify that the new motors worked before calling you saying it was ready. Is it a different problem?

Nice though that they offered to deliver once it IS fixed...take them up on that!!

On ours we decided to work through channels since new and under warranty and have the Jayco service dealer work with the factory who would contact Lippert. I have/had letters ready to send in case the parts sent by Lippert did not fix our issue.

Talking to Jayco tech support personally was very satisfying and felt their concern for our problem. Asking for and receiving Jayco's OK that Lippert would ship the parts overnight indicated to us that both were concerned with customer support.

Hopefully your issue will be resolved to get you back camping soon which is why we all spend the money in their products.

Note: There was no out of pocket expense when we picked up today...all warranty. Maybe there should be an inconvenience payment to us? Extra night in So. Cal before heading home and canceling of a trip last week? Just happy to have it home and hopefully issue solved.

Good luck and keep us informed.
__________________

__________________

2012 Pinnacle 36KPTS - Kitchen Pantry Triple Slide
Mor/Ryde suspension and pin box, Dual pane windows, Auto Leveling System, 2 A/C's, Sailun G's and more...
View photos

Our Trip Journal
Larry G. is offline   Reply With Quote
Old 04-13-2012, 10:26 PM   #23
Senior Member
 
Join Date: Jan 2012
Location: Lander, Wyoming
Posts: 588
Larry, the dealer told us on the phone and when we got there that they put the motors in and they worked just fine before they called us. Then they put the trailer out on the lot and when we came, the motors didn't work. I was able to, somehow or other, get the slide to go out one time and back in, but it kinda came in a bit at a time, one side would move and the other would catch up. When it got back in, nothing!!! So far, and I suspect, never, will there be any out-of-pocket cost on this. We bought the trailer on January 20, 2012 and it was manufactured in October, 2011. I haven't talked to Jayco yet, the dealer and tech have been talking to Lippert, as far as I know. Lippert has seemed willing to work with them, it's just been somewhat of a mess. We got the trailer home, opened and closed the bedroom slide a few times, then it just quit working. Didn't seem to work quite right, even when we did our walkthrough when buying the trailer. We'll see what happens. I even looked at a different FW, a Sundance XLT with almost the same floor plan and the wardrobe slide. Unfortunately, it had the built-in bike carrier, whatever and the frame was totally covered making it extremely difficult to put on the hitch I want to tow the boat. I tried to talk them into another trailer when getting the hitch put on, but they must have had a buyer on the hook because they wouldn't consider it. We'll just keep out fingers crossed. I am going to try to get Lippert to reimburse me for at least one trip for diesel and, in a fit of extreme greed, for about five hours of my time at $50 per hour that I could have been working here at home for my old firm, which is a little less than what they are paying me, but it is a nice round number.
jal0710 is offline   Reply With Quote
Old 05-02-2012, 07:58 AM   #24
Senior Member
 
Join Date: Jan 2012
Location: Lander, Wyoming
Posts: 588
Have to bring this up again. Got our FW back without the slide being fixed, Lippert hadn't shipped the parts as our dealer thought was promised. We were taking a trip and the dealer got the slide working using the override program in the controller. They delivered it, we checked out the slide and it "worked" but we held our breath each time we tried it. Towed it about 1,000 miles and the slide worked fine going out, but hesitated a bit going back in after a week. Got home and it worked fine but I do not plan on going out to the front storage area of the FW to work the slide each time we want to use it. Have an appointment for Thursday to get it fixed at the dealer, 150 miles away, and we'll see how it goes. My question of the day is this, how darn long should a person put up with this lack of performance on the part of the dealer and Lippert????? Do lemon laws apply to towed items or just to motored vehicles?
jal0710 is offline   Reply With Quote
Old 05-02-2012, 10:23 AM   #25
Senior Member
 
3'senough's Avatar
 
Join Date: Sep 2010
Location: New York
Posts: 2,072
Since you obviuosly spent the time and resources to bring it into the dealer once perhaps since Jayco and Lippert seem to have dropped the ball a call to Jayco might be in order. You might even try to get them to send a mobile team to fix your unit since the delay was not your fault and ample time was provided to service the unit.

Jayco seems to be fairly attentive to issues in my experience with them and others have seemed to fair well with some "squeaking" when needed. Having the dealer do it for you might not get the response as you an owner might receive as the sense of urgency is lost in translation.

Worth a call and e-mail. They will take a few days to get back via e-mail but they do get back. Also try Lippert directly.

Perhaps the ball dropped at the dealer?? Just my 2 cents.
__________________

2014 375 BHFS Eagle Premier
2014 Ram 3500 Longhorn DRW CC
6.7 CTD, Aisin, 4.10's
Yamaha EF3000iSEB
3'senough is offline   Reply With Quote
Old 05-02-2012, 10:55 AM   #26
Senior Member
 
Join Date: Jan 2012
Location: Lander, Wyoming
Posts: 588
I really don't know whether the dealer dropped the ball. I got a copy of an email directly to the tech at Lippert asking that the parts be shipped next day air on the Friday before the requested Monday shipping date. I also have sent two emails directly to the same address asking for a response and, as of today, have not received a response. Don't know if this is a Lippert problem or a problem with this particular tech. So we will go down to the dealer tomorrow and try to get it fixed. If they can't fix it this time, I agree it may be time to go to Jayco. We'll see after tomorrow.
__________________

jal0710 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.