Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-20-2017, 11:33 AM   #1
Junior Member
 
Join Date: Nov 2017
Location: Pella
Posts: 3
2010 Greyhawk 31FS

Hello,
I am searching for some help. I have a broken suspension part on my rear of the coach. I do believe it is a coach issue and not a Ford Chassis part. I am getting the run around from the Jayco rep and them telling me it is Ford, and Ford is telling me it is Jayco. I am attaching a couple of pictures. If anyone has an idea I would appreciate it. I have 2 pics, one shows the broken part the other is the side that is still attached.
Attached Thumbnails
20170728_111933.jpg   20170728_111942.jpg  
__________________

EAHALL is offline   Reply With Quote
Old 11-20-2017, 12:19 PM   #2
Member
 
Join Date: May 2017
Location: Brunswick
Posts: 73
Is something actually broken? I am not a suspension expert, but it looks like in the top picture the U-Bolt is loose. Are you able to tighten it?

Jayco installs the helper springs as a part of their J-Ride package. Not sure if Jayco was calling it J-Ride in 2010 or not. Our 2009 had the helper springs, but Jayco wasn't calling the system J-Ride yet. Any competent mechanic should be able to work on it. It isn't under warranty by either company, so I'm not sure why either won't work on it.

If you have a shop that works on big truck suspensions, they should be able to help you. From the picture, it looks like the U-Bolt just shifted. Shouldn't be hard to fix, even if something broke.

-Michael
__________________

michael.g is offline   Reply With Quote
Old 11-20-2017, 12:49 PM   #3
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 1,340
I agree with Michael, it looks like the extra U-bolt clamps you see when a helper spring was installed, but I don't see the helper spring itself. Hellwig is one company Jayco heas used as a supplier for those.

What does the other side look like in comparison?
__________________
Rob R.
Akron, OH
2014 Seneca 37TS
Toads: 2014 Ford Explorer Sport or 2013 Ford Focus ST
Robbbyr is online now   Reply With Quote
Old 11-20-2017, 01:14 PM   #4
Senior Member
 
Join Date: May 2016
Location: Honey Brook
Posts: 104
Thatís the hellwig suspension leafs.
Call hellwig and they should be able to help.


Sent from my iPhone using Tapatalk
Hivoltage98 is offline   Reply With Quote
Old 11-20-2017, 02:30 PM   #5
Senior Member
 
Join Date: Apr 2015
Location: Michigan
Posts: 1,330
I would just take it to a local frame/spring shop and have them fix it. I broke the top three springs on my F350 and they fell off, looked similar to what you have showing. The shop checked the other springs which were fine and added three new ones on top.
Sundancer330 is online now   Reply With Quote
Old 11-20-2017, 03:56 PM   #6
Junior Member
 
Join Date: Nov 2017
Location: Pella
Posts: 3
Ok i looked up on hellwig and didn't see they same style as this spring setup. I will get ahold of them.
Hopefully they will help me out.
EAHALL is offline   Reply With Quote
Old 11-20-2017, 09:54 PM   #7
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 912
For the record, MORryde does the chassis stuff, so Ford's close.
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 11-20-2017, 11:46 PM   #8
Senior Member
 
Join Date: Mar 2017
Location: Springfield
Posts: 215
It looks like that u bolt slipped off the helper spring. The half moon support needs to be put over the bent end of the helper spring and tightened down. Maybe look carefully at the threads on that loose bolt. Might be best to replace the bolt from Hellwig.
Slide the loose assembly back and look up at the helper spring. I think you'll see where it's suppose to fit.
t18skyguy is offline   Reply With Quote
Old 11-21-2017, 05:52 AM   #9
Senior Member
 
Join Date: May 2016
Location: Honey Brook
Posts: 104
Quote:
Originally Posted by EAHALL View Post
Ok i looked up on hellwig and didn't see they same style as this spring setup. I will get ahold of them.
Hopefully they will help me out.

http://www.hellwigproducts.com/produ...elper-springs/

I have a 2012 31FS and I have the same helper springs. It looks like the end of the spring snapped off where the u bolt attached.



Sent from my iPhone using Tapatalk
Hivoltage98 is offline   Reply With Quote
Old 11-21-2017, 10:36 AM   #10
Junior Member
 
Join Date: Nov 2017
Location: Pella
Posts: 3
Thanks for all the comments, th e u bolt isn't broke, but the hook piece the 1/2 moon rests in is. These clamps are right next to the u bolt clamp that clamps the factory springs to the axle.
I emailed hellwig, waiting to hear back.
__________________

EAHALL is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.