Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 01-15-2018, 04:59 PM   #1
Member
 
Join Date: Nov 2015
Location: Vineland
Posts: 66
Coleman Airconditioner not cooling

We have a 2016 Grayhawk 29MV with a Coleman 15,000 btu air conditioner/heat pump that would not cool today . The fan runs , I cant tell if the compressor runs yet . Is there anything else I need to check before I pull the cover ? I did trip a breaker this morning with the toaster and electric heater , that breaker reset OK
__________________

Davidmac is offline   Reply With Quote
Old 01-15-2018, 08:56 PM   #2
Senior Member
 
Join Date: Oct 2014
Location: Dallas
Posts: 339
What was the outside temp where you were at?


Sent from my iPad using Tapatalk
__________________

__________________
2017 Jayco Redhawk 29XK
2015 Wrangler JKU
Blue Ox Baseplate w/Avail Tow Bar & Protect-a-Tow
RViBrake2 w/TPMS
drk98 is online now   Reply With Quote
Old 01-16-2018, 06:07 AM   #3
Member
 
Join Date: Nov 2015
Location: Vineland
Posts: 66
outside temp was 70 deg
Davidmac is offline   Reply With Quote
Old 01-16-2018, 08:01 AM   #4
Senior Member
 
Jopopsy's Avatar
 
Join Date: Jun 2015
Location: Jackson
Posts: 1,159
Listen closely and see if the compressor is short cycling. Keep everything quiet and see if the compressor comes on for a few seconds, minute, and then turns off. If that's happening, I bet the air divider under the inside shroud is misaligned letting nice cold air get sucked back into the supply, and triggering the frost detector thermostat. Happened to mine 3x's. Field repaired 3x's. Bad design.
__________________
2018 Forest River Sunseeker 2420MS
Sold: 2015 Greyhawk 29MV, 2014 Jayco X17z, 2012 Jay Series 1207

Jopopsy is offline   Reply With Quote
Old 01-16-2018, 02:55 PM   #5
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 1,164
Quote:
Originally Posted by Jopopsy View Post
. Happened to mine 3x's. Field repaired 3x's. Bad design.
That air divider thing was a pure hack in our 31FK. Similar tale, 3 failures, 2 fixes that failed. Finally came up with a more permanent solution.

Bad, bad design.
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 01-19-2018, 08:43 AM   #6
Member
 
Join Date: Nov 2015
Location: Vineland
Posts: 66
I finally had a chance to inspect my ac unit . I appears that the intake screen was covered with dust . after washing the screens and inspecting the diverter the unit is working again at least the heat pump part is . It will have to warm up here in Florida to test to AC part .
Thanks for the input
Davemac
__________________

Davidmac is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jacyo, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.