Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-01-2020, 08:42 PM   #1
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 3,413
Equalizer system drivin' me nutz

The thing starts beeping all on its own now. We'll drive out to the storage lot after a week or so, and sure enough you can here it beeping as you walk up.


Today it would beep then stop as we drove off. Seems like bumps seemed to trigger it. Sometimes the parking brake will get it to stop, but not today.


Eventually, after 15 mins, it stopped beeping, stopped blinking...


Any ideas on what to look for?
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 03-02-2020, 08:40 AM   #2
Senior Member
 
Camper_bob's Avatar
 
Join Date: Sep 2013
Location: South Texas
Posts: 6,946
Dang, I was thinking the brake would stop it.

Maybe check out the wiring to whatever switch is attached to the brake? IDK, just guessing...
__________________

-2018 Greyhawk 29MV
-2020 Jeep Wrangler Unlimited (JLU) (Primary Toad)
-1994 Jeep Wrangler YJ (Secondary Toad)
-2014 Jay Flight 28BHBE & Ram 2500 6.4L CC 4x4 (sold)
Camper_bob is offline   Reply With Quote
Old 03-02-2020, 08:54 AM   #3
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 13,630
Low fluid would do that with the POWER GEAR System.
__________________
DISNEY LOVERS
Grumpy is online now   Reply With Quote
Old 03-02-2020, 03:44 PM   #4
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 3,413
It's all over the place on beeping, LEDs flashing. Sometimes two LEDs flash, sometimes all of them, sometimes none. Same thing with beeps.


I need to record some video of the thing and just send it to Equalizer support and see if they'll even bite.


My worry is that they'll punt and say "Take it to the dealer."


Which ain't going to happen...
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 03-02-2020, 03:50 PM   #5
Senior Member
 
Mark S's Avatar
 
Join Date: Feb 2017
Location: Davie, Fl.
Posts: 1,018
What did Equalizer customer support say about this?
__________________
Mark and Joanne
2018 Jayco Seneca 37TS (M2)
2023 Jeep Rubicon XT Recon
Mark S is offline   Reply With Quote
Old 03-02-2020, 04:31 PM   #6
Senior Member
 
Camper_bob's Avatar
 
Join Date: Sep 2013
Location: South Texas
Posts: 6,946
Quote:
Originally Posted by pconroy View Post
It's all over the place on beeping, LEDs flashing. Sometimes two LEDs flash, sometimes all of them, sometimes none. Same thing with beeps.


I need to record some video of the thing and just send it to Equalizer support and see if they'll even bite.


My worry is that they'll punt and say "Take it to the dealer."


Which ain't going to happen...
That's actually a good idea. In my experience, their support is decent. I say send it and see what they come back with.

Have you checked the ground? Or the wiring behind the panel?

Maybe you need an exorcist?
__________________

-2018 Greyhawk 29MV
-2020 Jeep Wrangler Unlimited (JLU) (Primary Toad)
-1994 Jeep Wrangler YJ (Secondary Toad)
-2014 Jay Flight 28BHBE & Ram 2500 6.4L CC 4x4 (sold)
Camper_bob is offline   Reply With Quote
Old 03-02-2020, 04:56 PM   #7
Junior Member
 
Join Date: Jul 2019
Location: Spring
Posts: 29
Quote:
Originally Posted by pconroy View Post
It's all over the place on beeping, LEDs flashing. Sometimes two LEDs flash, sometimes all of them, sometimes none. Same thing with beeps.


I need to record some video of the thing and just send it to Equalizer support and see if they'll even bite.


My worry is that they'll punt and say "Take it to the dealer."


Which ain't going to happen...

Welcome to the club. I have a 2019 seneca that is doing the same thing. Working with jayco to try to come up with a solution.
__________________
2019 Seneca 37TS
2015 Jeep Wrangler JK
BLUE OX/Air Force 1
Or
2018 F150 supercrew
Blue ox base plate and tow bar
M&G engineering brake system.
Jesslinger is offline   Reply With Quote
Old 03-02-2020, 06:22 PM   #8
Senior Member
 
hoppers4's Avatar
 
Join Date: Mar 2015
Location: Port Orchard
Posts: 2,007
There's a switch on each jack that is an indicator that the jack has been retracted. My driver side rear jack switch was intermittent. I slid a shim under the switch and cured the problem. Since then I've put a rubber boot over the end of the switch and the cure is permanent. After you've retracted the jacks, go around to each switch and push it up to determine which switch is giving you a headache.
__________________
Don
hoppers4 is offline   Reply With Quote
Old 03-02-2020, 06:30 PM   #9
Junior Member
 
Join Date: Jul 2019
Location: Spring
Posts: 29
Thanks for the info. But the beeping only occurs when the jacks are extended. This started occurring when I had the dash lights fixed on an Tsb from Jayco on the Freightliner interface. The problem occurs if I extend any or all jacks and then turn off the panel, it turns itself back on and beeps. The ignition on indicator flashes and beeps. I don’t even have the key in....this doesn’t happen if I have the jacks retracted..
__________________
2019 Seneca 37TS
2015 Jeep Wrangler JK
BLUE OX/Air Force 1
Or
2018 F150 supercrew
Blue ox base plate and tow bar
M&G engineering brake system.
Jesslinger is offline   Reply With Quote
Old 03-02-2020, 07:59 PM   #10
Senior Member
 
hoppers4's Avatar
 
Join Date: Mar 2015
Location: Port Orchard
Posts: 2,007
Quote:
Originally Posted by Jesslinger View Post
I donít even have the key in....this doesnít happen if I have the jacks retracted..
That sounds more like the leveler system is getting 12C onto it's "ignition on" line/wire. Somewhere along the wire 12V is mixing it up (intermittently) with this wire going to the leveler. This could be a faulty ignition switch, a piece of bare wire rubbing against 12V somewhere, or the control module for the leveler is defective.
__________________
Don
hoppers4 is offline   Reply With Quote
Old 03-02-2020, 11:57 PM   #11
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 3,413
Quote:
Originally Posted by Jesslinger View Post
Thanks for the info. But the beeping only occurs when the jacks are extended. This started occurring when I had the dash lights fixed on an Tsb from Jayco on the Freightliner interface. The problem occurs if I extend any or all jacks and then turn off the panel, it turns itself back on and beeps. The ignition on indicator flashes and beeps. I donít even have the key in....this doesnít happen if I have the jacks retracted..

And mine seems to occur when they're up.
I've been scared to drop them lest they get stuck in the down position.


I haven't talked to equalizer, yet...


loose ground sure sounds like it would produce the same issue.
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 03-03-2020, 05:13 PM   #12
Junior Member
 
Join Date: Jul 2019
Location: Spring
Posts: 29
Okay - possible solution. The pink wire in the attached photo of the back of the equalizer panel is the feed for the ignition on. So I cut the pink wire and added a 6 amp diode with the cathode end toward the control panel so that there would be no feedback from the equalizer control.. so far so good. When I turn on the ignition, the panel alerts as it should. Turned off the key. Let it auto level and turned off the equalizer. And it stayed off. . Then turned it back on and did an all retract. Hopefully this fixes my problem.
Attached Thumbnails
IMG_1263.jpg  
__________________
2019 Seneca 37TS
2015 Jeep Wrangler JK
BLUE OX/Air Force 1
Or
2018 F150 supercrew
Blue ox base plate and tow bar
M&G engineering brake system.
Jesslinger is offline   Reply With Quote
Old 03-03-2020, 10:16 PM   #13
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 3,413
Quote:
Originally Posted by Jesslinger View Post
Okay - possible solution. The pink wire in the attached photo of the back of the equalizer panel is the feed for the ignition on. So I cut the pink wire and added a 6 amp diode with the cathode end toward the control panel so that there would be no feedback from the equalizer control.. so far so good. When I turn on the ignition, the panel alerts as it should. Turned off the key. Let it auto level and turned off the equalizer. And it stayed off. . Then turned it back on and did an all retract. Hopefully this fixes my problem.



cool - but what's on the brown wire?
that looks like a diode in there under the shrink tube?
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 03-03-2020, 11:30 PM   #14
Junior Member
 
Join Date: Jul 2019
Location: Spring
Posts: 29
Yeah. You weren't supposed to notice the brown wire. A little bit of confusion with wire color in the picture jayco sent. looked brown to me but when it didn't work - jayco said purple wire. I got no purple wire. I knew that equalizer had told another seneca owner that cutting the pink wire would disable the ignition warning. So - I said what the heck let's try the pink wire..so I moved that diode to the pink wire -- voila it worked to everybody's surprise (so far anyway)
__________________
2019 Seneca 37TS
2015 Jeep Wrangler JK
BLUE OX/Air Force 1
Or
2018 F150 supercrew
Blue ox base plate and tow bar
M&G engineering brake system.
Jesslinger is offline   Reply With Quote
Old 03-07-2020, 01:32 PM   #15
Senior Member
 
Join Date: Oct 2018
Location: Out there somewhere
Posts: 1,342
I was going to install equalizer in my rig but I constantly see post of issues. But I’m wondering if having it installed by equalizer is better than the factory installation by Jayco?
Johnynorthland is offline   Reply With Quote
Old 03-07-2020, 01:54 PM   #16
Junior Member
 
Join Date: Aug 2015
Location: Salt Lake City
Posts: 1
Quote:
Originally Posted by pconroy View Post
The thing starts beeping all on its own now. We'll drive out to the storage lot after a week or so, and sure enough you can here it beeping as you walk up.


Today it would beep then stop as we drove off. Seems like bumps seemed to trigger it. Sometimes the parking brake will get it to stop, but not today.


Eventually, after 15 mins, it stopped beeping, stopped blinking...


Any ideas on what to look for?
I found the answer here, after we were having the same problem. Apparently it was low hydraulic fluid because we topped ours off and the problem disappeared. Thank goodness! Also the jacks might be dirty so they aren't fully retracting. Solution for that is a good wipe down with silicone spray. Best wishes to you!

Edit: Our was only beeping when retracted, while we were driving. But have you tried adding fluid?
specialslc is offline   Reply With Quote
Old 03-07-2020, 03:09 PM   #17
Junior Member
 
Join Date: Dec 2018
Location: Boynton Beach
Posts: 18
I had the same problem on my 2019 Seneca. Jacks were up and the panel would start flashing. I hit the retrack button(even while driving), and it would stop. Few minutes later, same flashing. Equilizer was very helpful, understood my problem, sent me a DV2 KIT. Took a few minutes to install underneath, no problems since.
Roll'n Olaf is offline   Reply With Quote
Old 03-07-2020, 03:24 PM   #18
Junior Member
 
Join Date: Jan 2019
Location: Satellite Beach
Posts: 25
'19 Seneca had the same beeping problem the day we took delivery at the dealer and they said they would order the kit. When they installed the parts later and have had not issues with beeping since. We just finished a 1000 mile trip with no issues. If you contact Equalizer they will send you the kit also.
mcdanger is offline   Reply With Quote
Old 03-08-2020, 08:11 AM   #19
Junior Member
 
Join Date: Oct 2019
Location: Key West
Posts: 15
Doghouse

Quote:
Originally Posted by pconroy View Post
The thing starts beeping all on its own now. We'll drive out to the storage lot after a week or so, and sure enough you can here it beeping as you walk up.


Today it would beep then stop as we drove off. Seems like bumps seemed to trigger it. Sometimes the parking brake will get it to stop, but not today.


Eventually, after 15 mins, it stopped beeping, stopped blinking...


Any ideas on what to look for?
We had the same thing on our 2017 Freedom Elite .There is a micro switch on each one. You can make the adjustments your self.
The Doghoues is offline   Reply With Quote
Old 03-08-2020, 08:26 AM   #20
Junior Member
 
Join Date: Oct 2018
Location: Bulverde
Posts: 1
The hydraulic fluid needs to be topped off for the equalizer. Same thing happened to us.
bdgoebel is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.