Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-26-2015, 07:29 AM   #1
Senior Member
 
Join Date: Mar 2015
Location: Riverview
Posts: 301
Generator no longer providing 110V

UGH - cant edit the title/subject. Providing...

Yesterday on the way home from a trip, we stopped for dinner. We turned the gen set on so that the dog would stay cool in the FL temps. When we got back the AC had never kicked on, the Microwave does not have anything lit up, and the ac won't even turn the fan on. I checke all the breakers in the distribution panel, but no luck. what else might be wrong? I heard from someone that there may be a breaker on the generator.

Any help would be appreciated.
__________________

__________________
________
Carl & Dawn
2015 Greyhawk 31FS
2015 Ford Transit Connect (our TOAD on a DEMCO Dolly)
DW, DSx2, DDx2 Catx2 Dog
Tampa Bay Area of FL
CarlB is offline   Reply With Quote
Old 05-26-2015, 07:45 AM   #2
Site Team
 
WVDusty's Avatar
 
Join Date: Feb 2014
Location: Charleston
Posts: 1,549
Sorry I cant help with your generator question. But I did fix your subject/title for you.
__________________

__________________
https://www.jaycoowners.com/forums/re...%3A_douuy_o5dq

TV 2005 Ram 3500 CC LB SRW Cummins POWER
2014 Jayco Jayflight 32BHDS Prodigy P3 brake controller.Reese dual cam 1400/14000
WVDusty is offline   Reply With Quote
Old 05-26-2015, 10:57 AM   #3
Senior Member
 
bgermane's Avatar
 
Join Date: Apr 2012
Location: Southern California
Posts: 171
There is a breaker on the generator. Remove the service cover from the generator. You will see a Start/Stop rocker switch. On the right side of the switch enclosure, there is a breaker. Cycle the breaker off and then back on. Then give things a try.
__________________
Brian, Mary, kids, beagle - Moose, and mutt - Maggie.
2012 Greyhawk 31FS
2013 Ford Explorer Toad
bgermane is offline   Reply With Quote
Old 05-26-2015, 03:28 PM   #4
Senior Member
 
Join Date: Mar 2015
Location: Riverview
Posts: 301
Cool I will give that a go. THANKS!
__________________
________
Carl & Dawn
2015 Greyhawk 31FS
2015 Ford Transit Connect (our TOAD on a DEMCO Dolly)
DW, DSx2, DDx2 Catx2 Dog
Tampa Bay Area of FL
CarlB is offline   Reply With Quote
Old 05-26-2015, 06:35 PM   #5
Senior Member
 
Join Date: Mar 2015
Location: Riverview
Posts: 301
Yes the breaker was thrown because dealer did not put the air filter back on properly after "fixing" it during the PDI. So the cover apparently went down onto some electrical component.
__________________
________
Carl & Dawn
2015 Greyhawk 31FS
2015 Ford Transit Connect (our TOAD on a DEMCO Dolly)
DW, DSx2, DDx2 Catx2 Dog
Tampa Bay Area of FL
CarlB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.