Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2019, 09:58 PM   #1
Junior Member
 
Join Date: Jun 2018
Location: Clarkston
Posts: 22
Greyhawk Auto-Level "Retract Error"

After having the house battery out for a bit the auto-leveling controller display says "Retract Error" with an indication that I need to see a service technician. Battery is back in, but the error remains. The jacks are completely up, but I want to put them down. I found this Lippert troubleshooting guide online, but it does not show this error.

Has anyone seen this error before? Any suggestions? Thanks!
jasoev is offline   Reply With Quote
Old 01-23-2019, 01:24 PM   #2
Senior Member
 
MFalcon's Avatar
 
Join Date: Apr 2015
Location: Belleville, Ontario
Posts: 134
My Big Foot System on my '15 31DS has a 120 amp auto reset circuit breaker on the underside of my rig, near the battery. I needed to tighten the connections ,on the circuit breaker to get my jacks to work. It's worth a look if you have this same circuit breaker. Cheers.
__________________
MFalcon
Belleville, Ontario Canada
2015 Greyhawk 31DS
2013 Jeep Wrangler
Blue Ox Tow Package
Blog: https://mfalcontraveler.wordpress.com/
MFalcon is offline   Reply With Quote
Old 01-23-2019, 01:56 PM   #3
75H
Member
 
Join Date: Jan 2019
Location: Chino Hills
Posts: 49
Scary Huh! We also disconnect batteries for storage and this also happened to us once after reconnecting power (jacks also up). I looked on the Internet, tried a suggestion of pressing retract & enter buttons simultaneously for a few (3-5) seconds, and crossed my fingers. The code cleared and jacks then tested and worked normally on level ground. No problems since.

Besides general web searching I've found that etrailer.com has a lot of great info and there is a MyLCI app in the app store.

2018 29MVP
75H is offline   Reply With Quote
Old 01-23-2019, 06:10 PM   #4
Senior Member
 
Join Date: Jun 2018
Location: USA
Posts: 237
Mine is real finicky about the voltage. Before I put the trik-l-start on, if I hadn't used the rig in a few days, I'd have to leave it running for 5 or 10 minutes before voltage was sufficient to operate the levelers.

Now the chassis battery is always topped off, it works right away, every time so far.
bababooey is offline   Reply With Quote
Old 01-23-2019, 06:35 PM   #5
Member
 
Join Date: May 2016
Location: Davisburg
Posts: 75
I had this happen also. You will have to remove the control panel from the wall, disconnect the plug for thirty seconds, then reconnect. I think it clears the error in the system.
Bobman is offline   Reply With Quote
Old 01-23-2019, 07:04 PM   #6
Junior Member
 
Join Date: Jun 2018
Location: Clarkston
Posts: 22
Guys thanks for all the great feedback. I just received a message back from Jayco, but they did not provide any useful help. They sent me essentially the same PDF I shared in my original post. It does not show the "Retract Error" either. I'll try out your suggestions this weekend. Thanks again!
jasoev is offline   Reply With Quote
Old 01-23-2019, 08:09 PM   #7
Member
 
Join Date: Aug 2014
Location: Allentown
Posts: 57
I did not get a manual for my LCI leveling system on my 2019 Greyhawk 31FSP. Does anyone know the model of the LCI levelers Jayco uses? I would like to get a manual online to have it in case I get errors or something like this happens to me.
Fishstick8 is offline   Reply With Quote
Old 01-24-2019, 06:53 AM   #8
Senior Member
 
Join Date: Oct 2018
Location: MATTAPOISETT
Posts: 234
I had a similar issue on my 2018 Greyhawk found a fuse on the hydraulic pump was slightly corroded because the cap was off it. (pump under coach behind battery box) with it making a poor connection caused voltage drop. replaced the fuse and added some dielectric grease solved the problem
Berjr is offline   Reply With Quote
Old 01-24-2019, 10:32 AM   #9
Senior Member
 
Camper_bob's Avatar
 
Join Date: Sep 2013
Location: South Texas
Posts: 7,227
I'm having a problem with mine too, but I'm pretty sure it is a physical problem (as opposed to a software or electronic problem). I think I have pump or manifold problem as the jacks will not build enough pressure to lift effectively, and there are no leaks in the system, and plenty of voltage. I will try to have a look at the fuse, but I doubt that's my issue.

For OP, try the retract and enter buttons at the same time to clear the error, and then try to use the manual mode to level. That's what I've been doing, and I can usually get close enough.

FWIW, I went through every troubleshooting guide I could find and tried all sorts of fixes without throwing parts at it, and it still doesn't work right. It worked fine for the first couple months too. I contacted LCI and they had me try one more thing that didn't work. Then they said I had gone as far as I could go and I should bring it in to a repair facility. Thankfully, LCI is willing to cover any diagnosis or repair under warranty directly. They even said if my repair service facility wasn't willing to bill LCI directly, they would reimburse me after I paid the shop for repairs. I asked specifically because one of my clients highly recommended a local shop, and I would like to use them if at all possible.

Anyway, sorry for the rambling...
__________________

-2018 Greyhawk 29MV
-2020 Jeep Wrangler Unlimited (JLU) (Primary Toad)
-1994 Jeep Wrangler YJ (Secondary Toad)
-2014 Jay Flight 28BHBE & Ram 2500 6.4L CC 4x4 (sold)
Camper_bob is offline   Reply With Quote
Old 01-26-2019, 10:14 PM   #10
Junior Member
 
Join Date: Jun 2018
Location: Clarkston
Posts: 22
Thanks for all the feedback. It was the recommendation made by 75H, pressing and holding the enter and retract buttons for a few seconds, that cleared the fault. I was able auto-level and drop down the stabilizers without issue.
__________________
jasoev
Clarkston, WA
2019 Greyhawk 26Y
2015 Jeep Wrangler Rubicon Unlimited
Ready Brute Elite Tow Bar
Blog: www.evansoutdooradventures.com/
jasoev is offline   Reply With Quote
Old 01-26-2019, 10:33 PM   #11
Senior Member
 
Big1's Avatar
 
Join Date: Nov 2015
Location: Lakewood, WA.
Posts: 4,578
I love it when a plan come together but I do hate it when problem come, I figure that it keep me from getting altimer or old people disease, lol.
__________________
2023 Jayco North Point 310RLTS
2022 GMC Denali Ultimate DRW
AirLift 5000 Airbag Ultimate
Retired Army MSG
Big1 is offline   Reply With Quote
Old 05-14-2019, 08:11 PM   #12
Junior Member
 
Join Date: May 2019
Location: Glennville
Posts: 1
Hey, this worked perfectly! Thanks a bunch. Worked fine last time we used it and whet to get set up and had an error that would not clear.
Mountain Girl is offline   Reply With Quote
Old 08-22-2021, 07:58 PM   #13
Junior Member
 
Join Date: Oct 2018
Location: Northern Colorado
Posts: 13
Quote:
Originally Posted by 75H View Post
Scary Huh! We also disconnect batteries for storage and this also happened to us once after reconnecting power (jacks also up). I looked on the Internet, tried a suggestion of pressing retract & enter buttons simultaneously for a few (3-5) seconds, and crossed my fingers. The code cleared and jacks then tested and worked normally on level ground. No problems since.

Besides general web searching I've found that etrailer.com has a lot of great info and there is a MyLCI app in the app store.

2018 29MVP
This post solved my dilemma and made my day! Thank you!!
COClassyRV is offline   Reply With Quote
Old 08-29-2021, 07:19 AM   #14
Senior Member
 
GABob's Avatar
 
Join Date: Aug 2018
Location: Atlanta
Posts: 514
I had the same thing happen to me about 9 months back. Battery died in storage, and when I charged it back up every time I started the engine I heard a beeping sound. Thought it was the CO2 sensor until I got to the campsite and tried to level. Site was good so I waited until I got the unit home. Was ready to take it for service when I read about the reset. Saved me a bunch of time and money, gas alone.
__________________
2019 Entegra Odyssey 31L
GABob is offline   Reply With Quote
Reply

Tags
auto-level, greyhawk, jacks, retract, stabilizer jacks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.