Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-12-2013, 10:36 AM   #1
Junior Member
 
Join Date: Jul 2012
Posts: 17
Hot Water Heater Issue

I have a 2005 Jayco Escapade Class C. My hot water heater does not stay lit when on gas. I start it from the control panel, sometimes hear a few bangs and it tries to start. Then it shows the DSI light. Sometimes it starts but doesn't stay lit. I have adjusted the flame but no luck. Anything else to check?
__________________

kennyc is offline   Reply With Quote
Old 08-06-2013, 11:03 AM   #2
Junior Member
 
Join Date: Jul 2012
Posts: 17
Bump. Any ideas?
__________________

kennyc is offline   Reply With Quote
Old 08-06-2013, 11:33 AM   #3
Senior Member
 
Join Date: Apr 2013
Location: Cleveland
Posts: 1,435
I don't know much about them, however I'm assuming you have tried cleaning the burner orifice? Spiders like to sometimes makes nests in there.
__________________
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote
Old 08-06-2013, 02:41 PM   #4
Senior Member
 
Join Date: Dec 2012
Location: Southern Indiana
Posts: 1,357
Kennyc, not sure what kind of water heater you have, Atwood or Suburban. I have a 10 gallon Atwood in my Eagle and it was acting just like yours, flame would go on for about 10 to 20 seconds and quit. In fact, it was doing all sorts of crazy things like trying to ignite while there was flame in the tube. I started messing with the wires from the mother board and it turned out that I had a loose ground wire from the board to the exhaust. Tightened it down and problems went away. As HeadHunter said, make sure ALL orifices are clear.
TCNashville is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.