Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-29-2015, 07:22 AM   #1
Junior Member
 
Join Date: Jul 2015
Location: Cumming
Posts: 4
House battery and generator connection

I have a 2015 Greyhawk 31FS. Had to replace the original battery. House power works fine but now gennny won't crank. Any help would be most welcome!
__________________

Allen is offline   Reply With Quote
Old 08-30-2015, 03:20 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 336
If you changed the battery yourself, look for look cables that were not connected after getting the new battery in the tray. It's very easy to overlook a cable, or for them to get caught behind something and not connected. Might also check to make sure the breaker(s) on the generator are in the correction position. A small power surge can sometimes trip them.
__________________

__________________
'08 Greyhawk 31SS
jimp is offline   Reply With Quote
Old 08-30-2015, 03:29 PM   #3
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,038
Or did you reverse the geny cables? The breakers on the geny have no connection to a no start situation I start mine all the time with the breakers off.
__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.