Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-25-2021, 01:01 PM   #1
Member
 
Join Date: May 2021
Location: chattanooga
Posts: 42
I think I messed up. First winterize

2016 melbourne 24k.

I'm trying to winterize. Watched several videos.....several.

I have a couple of problems at this point.

1. could not get hot water heater plug out. I mean I put all I had into it.
it is brass and looks like it was never removed, corroded big time.

I bypassed the water heater....under the fridge panel removed to access.

2 put it on the setting for winterize, 2 and 4 . It sucked up the antifreeze fine, but nothing came out the faucet. It sounded like a gurgling, bubbling sound where the hot water heater is. Empty anti freeze jug and just a small stream coming out of the cold faucet in the bathroom.

If I have a water heater full of antifreeze and cant get the plug out, anyone have any thoughts?

Thanks,

David7
David7 is offline   Reply With Quote
Old 11-25-2021, 02:49 PM   #2
Senior Member
 
Join Date: Jun 2016
Location: Denver
Posts: 3,351
Are you sure you're tugging on the drain plug and not the relief valve? Five years ago, we went from tanked to tankless. But my recollection of the tank was it had a white nylon drain plug lower left.
__________________
2016 Greyhawk 31FK
pconroy is offline   Reply With Quote
Old 11-25-2021, 04:42 PM   #3
Member
 
Join Date: May 2021
Location: chattanooga
Posts: 42
Im pretty sure it is the drain plug Im grying to loosen. . I wish it were the nylon plug but it is brass.
Not sure why the water pump pulled a gallon of antifreeze, but none comes out the faucet.
David7 is offline   Reply With Quote
Old 11-25-2021, 07:23 PM   #4
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 13,156
Quote:
Originally Posted by David7 View Post
I’m pretty sure it is the drain plug I’m grying to loosen. . I wish it were the nylon plug but it is brass.
Not sure why the water pump pulled a gallon of antifreeze, but none comes out the faucet.
Did you pump it into the fresh water tank and not the water heater?
__________________
DISNEY LOVERS
Grumpy is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.