Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 07-04-2017, 12:17 PM   #11
Member
 
Join Date: Aug 2016
Location: Randolph
Posts: 48
The jacks do move. Just don't have the lifting power they used to. I drained the fluid last night and it is spotless. I'm questioning the fluid it self. They call for atf fluid and the fluid I drained is clear. Looks more like hydraulic fluid. I'm going to call power gear tomorrow.
__________________

__________________
2006 Jayco Seneca 35GS
F419sr1 is offline   Reply With Quote
Old 07-05-2017, 07:40 AM   #12
Member
 
Join Date: Aug 2016
Location: Randolph
Posts: 48
I called power gear and spoke with the technical department. They seem to think it's the pump. The pressure should be 2150 to 3000 psi. The fluid dosnt have to be atf. A light weight hydraulic fluid will work fine too. I'll update when I have more information


Sent from my iPhone using Tapatalk
__________________

__________________
2006 Jayco Seneca 35GS
F419sr1 is offline   Reply With Quote
Old 07-06-2017, 09:28 AM   #13
Member
 
Join Date: Dec 2015
Location: Qualicum Beach
Posts: 39
Quote:
Originally Posted by F419sr1 View Post
I called power gear and spoke with the technical department. They seem to think it's the pump. The pressure should be 2150 to 3000 psi. The fluid dosnt have to be atf. A light weight hydraulic fluid will work fine too. I'll update when I have more information


Sent from my iPhone using Tapatalk
Gawd!!! Ihate it when i'm wrong
brandysdad is offline   Reply With Quote
Old 05-19-2018, 08:49 AM   #14
Junior Member
 
Join Date: May 2018
Location: Redding
Posts: 1
Hello. Our jayco is doing the same thing. Would you please let me know how you fixed yours. Thanks
jimjoannl is offline   Reply With Quote
Old 05-19-2018, 01:24 PM   #15
Member
 
Join Date: Aug 2016
Location: Randolph
Posts: 48
Quote:
Originally Posted by jimjoannl View Post
Hello. Our jayco is doing the same thing. Would you please let me know how you fixed yours. Thanks
Havenít yet. This year itís parked in a seasonal spot at the track. I used a jack to help it among to level. It stays once itís level. Itís the pump. Call them. They were very helpful
F419sr1 is offline   Reply With Quote
Old 05-19-2018, 01:25 PM   #16
Member
 
Join Date: Aug 2016
Location: Randolph
Posts: 48
Quote:
Originally Posted by jimjoannl View Post
Hello. Our jayco is doing the same thing. Would you please let me know how you fixed yours. Thanks
Havenít yet. This year itís parked in a seasonal spot at the track. I used a jack to help it along to level. It stays once itís level. Itís the pump. Call them. They were very helpful
__________________

F419sr1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.