Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-03-2014, 11:08 PM   #1
Senior Member
 
Join Date: Jul 2014
Location: Harrisburg, PA
Posts: 173
New 2014 Seneca 37FS Owner with some questions

Hello all. This is the first and last Seneca this dealer bought/sold so they didn't know much about the unit to give me a real walk through. So I have some questions and hope all you existing owners can help.

1) When do you use the engine block heater?
2) The outside stereo won't turn on. The TV turns on though.
3) Is there a way to keep the rear camera on when I'm towing my car?
4) The passenger-side slide worked on the lot, but when I got it home it didn't want to go out...no reaction to pressing the switch. I'm following the same sequence from my old Class C...engine running, E brake on to operate the slide.
5) Spare tire. Has anyone thought of mounting a spare underneath or do we just rely on roadside assistance? Having the spare rim/wheel makes it a lot easier one would think.

Thanks in advance all.
__________________

Shultz01 is offline   Reply With Quote
Old 08-04-2014, 09:36 AM   #2
Member
 
RULazy2's Avatar
 
Join Date: Jul 2014
Location: Anderson Creek, NC
Posts: 45
I hope some of this will help:

1. I have not run into a situation where I had to use the engine block heater, though typically it is when the temperatures get below freezing to keep the fuel from gelling up on you.

2. The outside stereo might be wired wrong, you would either have to make a warranty call or take it out to see.

3. You can keep the rear camera on by hitting "menu" then scrolling over to "camera" on your head unit. You can then switch back to navigation or whatever by pressing the "nav/av" button just below the menu button.

4. There might be two things going on here...did you have your kill switch on? More than likely, though, it is in the wiring for the coach. I cannot do anything house related while the ignition is on. It was explained to me that it is a safety thing. Weird because my last coach had to have the ignition on to run the jacks, but my Seneca has to be off to use the jacks...don't know...maybe someone can help us both out.

5. A spare tire becomes at least two spares...the front tires do not fit on the back and vice versa, so if you are looking to run a spare, then you have to have a front set up and a dually set up which is more expensive than I feel like paying...roadside assistance is the way I go, and the DW and I have a tire insurance program...

There are also a few things you can do to help out while driving...the wife and I ran a 5 foot extension cord up through the opening on the side of the microwave and use magnet hooks to keep it out of the way. This allows us to unplug the micro and plug in the extension so we can have a crock pot going in the sink while we drive. Only two plugs are wired to run on the inverter, the micro and the cabover TV so it makes for an option while driving rather than run the generator.

Enjoy your coach!
__________________

__________________
2014 Seneca 37FS, 2012 Mazda2 on a Master Tow dolly
RULazy2 is offline   Reply With Quote
Old 08-04-2014, 08:57 PM   #3
Member
 
Join Date: Jun 2013
Posts: 70
Go without the spare. Those 22.5 inch tires are heavy not to mention jacking the thing.
greyhawk885 is offline   Reply With Quote
Old 08-05-2014, 05:12 AM   #4
Senior Member
 
Join Date: Jul 2014
Location: Harrisburg, PA
Posts: 173
Thanks everybody.

I'm good on everything except the outside stereo.

It appears it was a loose wire. When I pulled it to check the connections the no power issue fixed itself. BUT...there's no sound when tuned to a local station. I even tested it with a different speaker. No sound. I can see the equalizer moving on the display, but nothing. It has video output to the TV, but no audio there either. Any suggestions.

I already sent a message to Jayco's warranty department.
Shultz01 is offline   Reply With Quote
Old 08-05-2014, 09:25 AM   #5
Junior Member
 
cwasp's Avatar
 
Join Date: May 2014
Location: Shell beach
Posts: 13
Hello, I have a 2014 37TS. Have you experienced any transmission noise? Sounds like a chirping noise while in OD!!
I also agree on the spare issue. No need for that much weight.
Thanks in advance!
cwasp is offline   Reply With Quote
Old 08-05-2014, 12:12 PM   #6
Member
 
RULazy2's Avatar
 
Join Date: Jul 2014
Location: Anderson Creek, NC
Posts: 45
cwasp the chirping sound has a fix. Freightliner has a service bulletin out on it, ask your FL people to find the shift cable isolator technical service bulletin.
__________________
2014 Seneca 37FS, 2012 Mazda2 on a Master Tow dolly
RULazy2 is offline   Reply With Quote
Old 08-05-2014, 12:24 PM   #7
Member
 
RULazy2's Avatar
 
Join Date: Jul 2014
Location: Anderson Creek, NC
Posts: 45
Schultz, stereos are pretty straight forward. Hopefully Jayco will help you out but it sounds like the speaker is not connected, further it sounds like the failed connection is at the speaker, not the rear of the head unit, or the head unit is bad. Sorry I could not be more help.
__________________
2014 Seneca 37FS, 2012 Mazda2 on a Master Tow dolly
RULazy2 is offline   Reply With Quote
Old 08-05-2014, 01:58 PM   #8
Junior Member
 
cwasp's Avatar
 
Join Date: May 2014
Location: Shell beach
Posts: 13
Thanks RULazy2. I had that fix done, but the noise is still there, just quieter.
cwasp is offline   Reply With Quote
Old 08-07-2014, 12:29 PM   #9
Senior Member
 
Mr.Oz's Avatar
 
Join Date: Jul 2014
Location: Hebron
Posts: 214
Quote:
Originally Posted by cwasp View Post
Thanks RULazy2. I had that fix done, but the noise is still there, just quieter.
So is mine.....gonna do some mods of my own to see if I can totally
eliminate the noise.
__________________
Dan
2014 Seneca 37 FS
2014 Jeep Wrangler Sahara Unlimited
Mr.Oz is offline   Reply With Quote
Old 08-07-2014, 01:21 PM   #10
Junior Member
 
cwasp's Avatar
 
Join Date: May 2014
Location: Shell beach
Posts: 13
Thanks Dan, I have taken to a couple of shops now and they all give me the deer in the headlights look. I think part of the problem is the freightliner shops typically deal with big trucks and not MH's.
Please let me know if you find out anything else. I'm gonna contact Jayco again and get them involved. I paid too much money to have to accept a default that they have known about for years!
Gene
__________________

cwasp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.