Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-03-2013, 09:21 PM   #1
Junior Member
 
Join Date: Aug 2012
Posts: 19
No power to coach.

Took 2013 Greyhawk out of storage. Plugged into house current and nada to coach except microwave light. Checked breakers and fuses at foot of bed. All look ok and can hear the panel humming like it does. What am I missing? All fine when put away for winter, unit only has 3500 miles.
__________________

cinandtim is offline   Reply With Quote
Old 04-03-2013, 09:49 PM   #2
Senior Member
 
reitrof's Avatar
 
Join Date: Dec 2011
Location: Ottawa
Posts: 360
If you run the genny do the lights work?
__________________

__________________
Bruce

2012 Greyhawk 31 FK
Flat towing a 2008 Miata.
reitrof is offline   Reply With Quote
Old 04-04-2013, 07:26 AM   #3
Member
 
Join Date: Jun 2012
Location: Zachary, LA
Posts: 62
Sounds like you have AC power to the microwave outlet. Do you know if you have power to your other outlets? Also, the lights are run off the 12Vdc power. If you pushed your batter disconnect button when you put it in storage, it disconnected your coach battery from your coach and the lights and other dc powered items wont come on. You may have also hit it accidentally, I have done it before. Push the disconnect button and then see if your lights come on.
Troy M is offline   Reply With Quote
Old 04-04-2013, 08:09 AM   #4
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,047
If the coach battery went dead it would automatically disconnect as well. As Troy M said, that's where to start.
__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 04-04-2013, 08:14 AM   #5
Senior Member
 
Seann45's Avatar
 
Join Date: Jun 2010
Location: Saskatoon Sask Canada
Posts: 9,701
It is new you have a 2 year warranty take it too the dealer...
__________________
Seann
2004 Chev Silverado Duramax optioned past the max. 2009 Jayco Eagle 308 RLS 765 watts of solar, 6-6 volt batteries (696 amp hour), 2000 watt (4000 surge) whole house inverter.
175 days boondocking in 2017
215/2016, 211/2015, 196/14, 247/13, 193/12

Seann45 is offline   Reply With Quote
Old 04-04-2013, 10:45 AM   #6
Senior Member
 
TX_Arvee's Avatar
 
Join Date: May 2012
Location: Pearland, TX
Posts: 514
I would bet on the dead battery as well. Check the disconnect and battery.
__________________

TX_Arvee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.