Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-02-2022, 08:48 PM   #1
Member
 
Join Date: Mar 2021
Location: Scottsdale
Posts: 59
No tail lights/marker lights

2022 Odyssey 25R.

Just realized my taillights and (rear) marker lights are out. Brake lights, reverse lights, and turn signals are still working. Too hot and dark out right now to start taking a look.

Any ideas that I can start with once it gets light out in the morning?
ait109 is offline   Reply With Quote
Old 09-03-2022, 07:14 AM   #2
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 9,009
I doubt it is a grounding issue, as other lights in the unit work.

I would first check the fuses and relays.

Could be a bad wiring connection between where the coach frame and where Jayco plugged in the frame harness. To find that crawl under the MH.
__________________

2012 Jayco X23B
2020 Ram Laramie 3500 SRW Air ride 50Gal fuel tank.
2007 Dodge Dakota Quad Cab (retired from towing)
Equal-I-zer 4-Point Sway Control
Jagiven is offline   Reply With Quote
Old 09-03-2022, 07:39 AM   #3
Senior Member
 
Happy wife / happy life's Avatar
 
Join Date: Feb 2019
Location: Northern California
Posts: 1,086
Do your headlights work? The taillights and markers are run threw the headlight switch. I’m not familiar with your rig but I would 1st check to see if you have a headlight fuse. As “ Jagiven “ said then move on to your wiring connections. Best of luck to you!
__________________
1984 gmc k1500 4x4 s/w/b. s/b 350,700r4,373 diff,.restored and upgraded. 2018 hummingbird Baja 16mrb,Yamaha ef2400ishc inverter.
Happy wife / happy life is offline   Reply With Quote
Old 09-03-2022, 09:27 AM   #4
Member
 
Join Date: Mar 2021
Location: Scottsdale
Posts: 59
All the chassis lights work except for the tail lights. Brake lights and reverse lights are working. Front parking lights in the chassis are working. Turn signals and hazards work.

Front marker lights on top of the cabover are not working. Rear marker lights are not working. Rear tail (parking) lights are not working.

I'm getting a good tail light signal to the towing harness. If I can't figure this out in the next hour I'll just use my magnetic tow lights on the bumper for this weekend's trip.
ait109 is offline   Reply With Quote
Old 09-03-2022, 09:51 AM   #5
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 13,447
As Jagiven said check the fuses. If I remember correctly, there are two, one for the towing harness and one for the lights on the box itself.
__________________
DISNEY LOVERS
Grumpy is offline   Reply With Quote
Old 09-03-2022, 10:57 AM   #6
Member
 
Join Date: Mar 2021
Location: Scottsdale
Posts: 59
The 2022 Ford manual doesn't specifically call out a taillight or license plate fuse and I checked every thing related to lights and/or upfitter and they all visually check out. I'll test again with a multimeter once I get to a cooler location. No obvious wiring problem underneath the chassis. I tried to remove my rear left taillight assembly to check power but it's too caulked in and I'm on a timeline to get underway.

Thanks and I'll give an update in a few days.
ait109 is offline   Reply With Quote
Old 09-30-2022, 02:34 PM   #7
Member
 
Join Date: Mar 2021
Location: Scottsdale
Posts: 59
Took it to the dealer for some other warranty issues. Of course the lights worked when I got there. They took a quick look and couldn't find anything loose.

Did 4 hour drive after sunset this week, I could see that the marker lights stayed on the entire drive through my side view mirrors.

This is a very unsatisfactory resolution for me.
ait109 is offline   Reply With Quote
Old 09-30-2022, 02:35 PM   #8
Member
 
Join Date: Mar 2021
Location: Scottsdale
Posts: 59
Update

Took it to the dealer for some other warranty issues. Of course the lights worked when I got there. They took a quick look and couldn't find anything loose.

Did 4 hour drive after sunset this week, I could see that the marker lights stayed on the entire drive through my side view mirrors.

This is a very unsatisfactory resolution for me.
ait109 is offline   Reply With Quote
Old 10-03-2022, 10:00 AM   #9
Senior Member
 
Scoutmaster253's Avatar
 
Join Date: Apr 2018
Location: Ravenna
Posts: 298
Quote:
Originally Posted by ait109 View Post
Took it to the dealer for some other warranty issues. Of course the lights worked when I got there. They took a quick look and couldn't find anything loose.

Did 4 hour drive after sunset this week, I could see that the marker lights stayed on the entire drive through my side view mirrors.

This is a very unsatisfactory resolution for me.
The vibration from the trip caused some corroded connection somewhere to wear itself back together, re-making the connection. It will be fine until you park it again for a longish length of time.
__________________
2014 Greyhawk 31FS
RV's, Pop-ups, and Tents going back to the 1960's
Scoutmaster253 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.