Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-23-2014, 01:18 AM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 4
Odor from hot water tank

We have a 2014 Redhawk 26xs, bought new in February of this year. Last time we used it the hot water had a "rotten egg" odor. Couldn't even use the hot water it smelled so bad.. Anyone have this problem? What is the solution? I called the service department & they said they would have to look at it & the down time was 2 weeks. We tried putting the vinegar in the tank as suggested in book & then flushing. Seemed okay until we were out camping, the odor came back. Any ideas?? Thanks..
__________________

dragracin is offline   Reply With Quote
Old 09-23-2014, 04:42 AM   #2
Moderator Emeritus
 
Rustic Eagle's Avatar
 
Join Date: Apr 2011
Location: Michigan
Posts: 7,370
Welcome to JOF

Check out these recent JOF thread on the sam subject, they may be helpful:

https://www.jaycoowners.com/forums/sh...highlight=odor

https://www.jaycoowners.com/forums/sh...ghlight=bleach

Also, refer to your owners manual index for "Sanitizing the Plumbing System".

Bob
__________________

2016 GM 2500HD 6.0L/4.10
2018 Jay Flight 24RBS
2005 Jayco Eagle 278FBS (retired)
1999 Jayco Eagle 246FB (retired)
Reese HP Dual Cam (integrated sway control)
Rustic Eagle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.