Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-03-2016, 08:18 PM   #21
Senior Member
 
jgerhard's Avatar
 
Join Date: Oct 2015
Location: La Crescenta
Posts: 223
Okay thanks. Yea, looks like there is no signal meter anymore. The rep mentioned an in-line signal meter king jack offers but I didn't like it. Where would I mount it where I could use it anyway? I emailed king jack and they dont offer the built in signal meter separately, only the complete unit.
__________________

jgerhard is offline   Reply With Quote
Old 06-04-2016, 07:18 AM   #22
Senior Member
 
The Logans's Avatar
 
Join Date: May 2014
Location: Ona
Posts: 631
When our built in signal meter didn't work (because the electronics were missing), we bought the in-line unit. Save your money, it has never worked, and the 9v battery is only good for about a week.

Now we're going to have to pay to replace the entire unit, which was supposed to have been there in the first place. Extremely FRUSTRATING....

Looking back, kind of funny... the dealer tech tried to show us how to use the signal meter during the PDI, and when he popped the cover off, it was empty... no electronics.
__________________

__________________
The Logan's
2018 Jayco Alante 31v
Me, Dear Wife,
2 Bluetick Hounds
1 Newfoundland
1 Newfoundland / Black Lab Mix
1 Cairn Terrier
The Logans is offline   Reply With Quote
Old 06-04-2016, 08:00 AM   #23
Member
 
Join Date: May 2016
Location: Chelsea
Posts: 52
Seems shady to me. They advertise it on the main jayco site even on the 2017 ones. When comparing coaches it seemed like a box to check.

Have other bigger issues now though.
foglght is offline   Reply With Quote
Old 06-04-2016, 02:43 PM   #24
Senior Member
 
jgerhard's Avatar
 
Join Date: Oct 2015
Location: La Crescenta
Posts: 223
Yea I agree, shady for sure.

I hope your new bigger issues aren't too serious!

- James
jgerhard is offline   Reply With Quote
Old 06-06-2016, 07:55 PM   #25
Junior Member
 
Join Date: Mar 2016
Location: Colorado Springs
Posts: 12
We bought the same rig. 2016 Greyhawk 31FS. We are not happy either. Owned it 3 months and have only been able to use it once.

The POS tankless heater would not work at all. Dealer couldn't get it in for a month. Upon repair they found wires disconnected and a bad switch.

Front end alignment needed.

Leveling jacks too low but dealer won't adjust them and said if we do they will void the warranty.

Drive shaft vibration is terribly annoying. Repair needed.

Hitch not secured properly. Tried attaching trailer and the hitch shifted and actually caused the bumper to move.

Electric plug in kitchen shorted out.

So far not happy, not impressed.
__________________
2016 Greyhawk 31FS
TheGriswalds is offline   Reply With Quote
Old 06-07-2016, 07:05 AM   #26
Senior Member
 
Join Date: Jun 2015
Location: Jackson
Posts: 1,038
Quote:
Originally Posted by TheGriswalds View Post
We bought the same rig. 2016 Greyhawk 31FS. We are not happy either. Owned it 3 months and have only been able to use it once.

The POS tankless heater would not work at all. Dealer couldn't get it in for a month. Upon repair they found wires disconnected and a bad switch.

Front end alignment needed.

Leveling jacks too low but dealer won't adjust them and said if we do they will void the warranty.

Drive shaft vibration is terribly annoying. Repair needed.

Hitch not secured properly. Tried attaching trailer and the hitch shifted and actually caused the bumper to move.

Electric plug in kitchen shorted out.

So far not happy, not impressed.
The water heater should've been tested/verified on the dealer PDI. If it has a bad switch and disconnected wires, your dealer never tested it before selling it to you. That's 100% on the dealer - the water heater itself is good if you are not boondocking and understand how the heater itself works.

They all need a front end alignment. All of them.

Leveling jacks should be 7-8" off the ground when fully retracted. It will not void your warranty by raising them. Its just a couple bolts/nuts and moving the assembly up a hole or two. Again - your dealer is failing you.

Drive shaft vibration on the newer Ford chassis has been known for some time now. I'm the one who first discovered it for this particular forum as I was about to buy a 2016 Greyhawk but instead opted for a 2015. AGAIN - your dealer is failing you.

The hitch I could see being missed on a PDI - if they even did one for you.

The plug in the kitchen not so much.

I would not be a fan of your dealer.
__________________
Currently between RV's, and it might stay that way !
2017 F-150 XLT 3.5 EcoBoost 10 Speed SCREW Short Bed 3.55 rear axle - 1818 lbs payload
Sold: 2015 Greyhawk 29MV, 2014 Jayco X17z, 2012 Jay Series 1207

Jopopsy is offline   Reply With Quote
Old 06-13-2016, 06:50 PM   #27
Member
 
Join Date: May 2016
Location: Chelsea
Posts: 52
So, I think the dealer is now trying to correct a lot of the issues. More just keep popping up. I spent the entire weekend wiring in a TPMS system, hard wired surge protector and washing/polishing/wax-sealing the entire rig.

Found 5 more issues including cracks in the fiberglass cap and cracks in the running board. There was missing/cracked caulk as well. I found goobers of silicone on the front cap and it was impossible on some of them to remove so I gave up. I have no idea why gobs of silicone would be on the cap. The stickers are already peeling on the front cap as well.

Nav doesn't work. I keep wondering if I am using it wrong. Every time I hit the button for nav, it just beeps at me. The two times I tried it were sitting in my driveway and also on the highway on the way back to the dealer.

BTW, if you were ever trying this and wondering:

The Jensen radio is set up to play DVD's. Duh. Well the radio has the capability to run 2 zones of audio. If wired correctly (and the TV relay undone), the kids can watch a movie while you listen to the radio. You would just have to fade the sound all the way to the front for the radio so you don't have the rest of the coach speakers playing. Unfortunately, the explanation I got from the dealership was that Jayco doesn't wire it that way.

Got the same response on the king jack. They just aren't installing the electronics.

The dealer is apparently getting mixed signals from Jayco and Hellwig on the springs when I asked for them to be adjusted.

I've spent probably 10 hours total chasing rattles, squeaks and such. I haven't found a solution for everything and there is one large one I can't figure out what it is yet. I will need the wife to drive down the road while I listen for it. Lots of foam, weather seal strips, rubber vaccuum line, zip ties, etc. to get them to all quiet down.

The most unfortunate part was while the dealer had the coach for repair, they took it for an alignment. Apparently, Belle Tire smashed the rear corner into something and messed up the bumper and the corner of the coach.





They are fixing it, but apparently trim pieces from Jayco take at least a week to come in.

Oh, and I can't get a single person from Jayco to actually call me back or answer the phone. I've been on hold twice for over a 1/2 hour and nothing.

It's just not my year....
__________________

foglght is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.